summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/foomatic/foomatic-filters_4.0.17.bb
diff options
context:
space:
mode:
authorConstantin Musca <constantinx.musca@intel.com>2012-08-23 14:45:00 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-08-24 17:32:55 +0100
commit397650e358aade2a4e64ae07cd8ed6e8d6729e9b (patch)
tree0bf773113bba274c79b5ae4a086d6e789168f3f1 /meta/recipes-extended/foomatic/foomatic-filters_4.0.17.bb
parentae751ab589806ecef70c434cf561316424ae52a0 (diff)
downloadpoky-397650e358aade2a4e64ae07cd8ed6e8d6729e9b.tar.gz
foomatic-filters: upgrade to 4.0.17
(From OE-Core rev: ff64550810754f9f061015507719e3082272cbb3) Signed-off-by: Constantin Musca <constantinx.musca@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/foomatic/foomatic-filters_4.0.17.bb')
-rw-r--r--meta/recipes-extended/foomatic/foomatic-filters_4.0.17.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-extended/foomatic/foomatic-filters_4.0.17.bb b/meta/recipes-extended/foomatic/foomatic-filters_4.0.17.bb
new file mode 100644
index 0000000000..bb01f71d01
--- /dev/null
+++ b/meta/recipes-extended/foomatic/foomatic-filters_4.0.17.bb
@@ -0,0 +1,40 @@
1SUMMARY = "OpenPrinting printer support - filters"
2DESCRIPTION = "Foomatic is a printer database designed to make it easier to set up \
3common printers for use with UNIX-like operating systems.\
4It provides the "glue" between a print spooler (like CUPS or lpr) and \
5the printer, by processing files sent to the printer. \
6 \
7This package consists of filters used by the printer spoolers \
8to convert the incoming PostScript data into the printer's native \
9format using a printer-specific, but spooler-independent PPD file. \
10"
11
12DEPENDS += "cups perl libxml2"
13PR = "r0"
14
15LICENSE = "GPLv2+"
16LIC_FILES_CHKSUM = "file://${WORKDIR}/foomatic-filters-${PV}/COPYING;md5=393a5ca445f6965873eca0259a17f833"
17
18SRC_URI = "http://www.openprinting.org/download/foomatic/foomatic-filters-${PV}.tar.gz"
19
20SRC_URI[md5sum] = "b05f5dcbfe359f198eef3df5b283d896"
21SRC_URI[sha256sum] = "a2e2e53e502571e88eeb9010c45a0d54671f15707ee104f5c9c22b59ea7a33e3"
22
23inherit autotools
24
25EXTRA_OECONF += "--disable-file-converter-check --with-file-converter=texttops"
26
27do_configure_prepend() {
28 export PERL="${bindir}/env perl"
29 export LIB_CUPS=${exec_prefix}/lib/cups # /usr/lib NOT libdir
30 export CUPS_BACKENDS=${exec_prefix}/lib/cups/backend # /usr/lib NOT libdir
31 export CUPS_FILTERS=${exec_prefix}/lib/cups/filter # /usr/lib NOT libdir
32 export CUPS_PPDS=${datadir}/cups/model
33}
34
35do_install_append_linuxstdbase() {
36 install -d ${D}${exec_prefix}/lib/cups/filter
37 ln -sf ${bindir}/foomatic-rip ${D}${exec_prefix}/lib/cups/filter
38}
39
40FILES_${PN} += "${exec_prefix}/lib/cups/ ${exec_prefix}/lib/ppr/"