summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/findutils/findutils_4.4.2.bb
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2012-04-16 11:04:50 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-04-26 10:05:08 +0100
commit46ffeed9183ec12ff20dbb5c5b46ea35555835d5 (patch)
tree7353d6e5f69aa4c1469b908a52257b6cbf3e94fd /meta/recipes-extended/findutils/findutils_4.4.2.bb
parentf264a10d4ffbae5ee1ba6e6f1523d402df8a800d (diff)
downloadpoky-46ffeed9183ec12ff20dbb5c5b46ea35555835d5.tar.gz
findutils: Use update-alternatives
Change to using update-alternatives to ensure that we're consistently using the class, and the package provides are being setup properly. (From OE-Core rev: be2dbd1abfb4e0e6989d1c34c09047e439d8194e) Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/findutils/findutils_4.4.2.bb')
-rw-r--r--meta/recipes-extended/findutils/findutils_4.4.2.bb17
1 files changed, 1 insertions, 16 deletions
diff --git a/meta/recipes-extended/findutils/findutils_4.4.2.bb b/meta/recipes-extended/findutils/findutils_4.4.2.bb
index b2898ed5d9..d80511c4dc 100644
--- a/meta/recipes-extended/findutils/findutils_4.4.2.bb
+++ b/meta/recipes-extended/findutils/findutils_4.4.2.bb
@@ -1,6 +1,6 @@
1require findutils.inc 1require findutils.inc
2 2
3PR = "r2" 3PR = "r3"
4 4
5SRC_URI += "file://01-27017.patch \ 5SRC_URI += "file://01-27017.patch \
6 file://02-28824.patch \ 6 file://02-28824.patch \
@@ -13,19 +13,4 @@ SRC_URI[sha256sum] = "434f32d171cbc0a5e72cfc5372c6fc4cb0e681f8dce566a0de5b6fccd7
13# http://savannah.gnu.org/bugs/?27299 13# http://savannah.gnu.org/bugs/?27299
14CACHED_CONFIGUREVARS += "${@base_contains('DISTRO_FEATURES', 'libc-posix-clang-wchar', 'gl_cv_func_wcwidth_works=yes', '', d)}" 14CACHED_CONFIGUREVARS += "${@base_contains('DISTRO_FEATURES', 'libc-posix-clang-wchar', 'gl_cv_func_wcwidth_works=yes', '', d)}"
15 15
16do_install_append () {
17 if [ -e ${D}${bindir}/find ]; then
18 mv ${D}${bindir}/find ${D}${bindir}/find.${PN}
19 mv ${D}${bindir}/xargs ${D}${bindir}/xargs.${PN}
20 fi
21}
22
23pkg_postinst_${PN} () {
24 for i in find xargs; do update-alternatives --install ${bindir}/$i $i $i.${PN} 100; done
25}
26
27pkg_prerm_${PN} () {
28 for i in find xargs; do update-alternatives --remove $i $i.${PN}; done
29}
30
31BBCLASSEXTEND = "native" 16BBCLASSEXTEND = "native"