diff options
author | Richard Purdie <rpurdie@linux.intel.com> | 2010-09-01 19:09:11 +0100 |
---|---|---|
committer | Richard Purdie <rpurdie@linux.intel.com> | 2010-09-01 19:09:57 +0100 |
commit | d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612 (patch) | |
tree | f36fe3008f36ff75cbdd31b630f8f13f1f205ebb /meta/recipes-extended/findutils/findutils_4.2.31.bb | |
parent | caab7fc509bf27706ff3248689f6afd04225cfda (diff) | |
download | poky-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.gz |
packages: Separate out most of the remaining packages into recipes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/findutils/findutils_4.2.31.bb')
-rw-r--r-- | meta/recipes-extended/findutils/findutils_4.2.31.bb | 37 |
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-extended/findutils/findutils_4.2.31.bb b/meta/recipes-extended/findutils/findutils_4.2.31.bb new file mode 100644 index 0000000000..2804a3ba3a --- /dev/null +++ b/meta/recipes-extended/findutils/findutils_4.2.31.bb | |||
@@ -0,0 +1,37 @@ | |||
1 | DESCRIPTION = "find, locate, and xargs binaries." | ||
2 | HOMEPAGE = "http://www.gnu.org/software/findutils/" | ||
3 | BUGTRACKER = "http://savannah.gnu.org/bugs/?group=findutils" | ||
4 | SECTION = "console/utils" | ||
5 | |||
6 | LICENSE = "GPLv2+" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552" | ||
8 | PR = "r1" | ||
9 | |||
10 | SRC_URI = "${GNU_MIRROR}/findutils/findutils-${PV}.tar.gz \ | ||
11 | file://gnulib-extension.patch" | ||
12 | |||
13 | inherit autotools gettext | ||
14 | |||
15 | # diffutils assumes non-glibc compilation with uclibc and | ||
16 | # this causes it to generate its own implementations of | ||
17 | # standard functionality. regex.c actually breaks compilation | ||
18 | # because it uses __mempcpy, there are other things (TBD: | ||
19 | # see diffutils.mk in buildroot) | ||
20 | EXTRA_OECONF_linux-uclibc = "--without-included-regex" | ||
21 | |||
22 | do_install_append () { | ||
23 | if [ -e ${D}${bindir}/find ]; then | ||
24 | mv ${D}${bindir}/find ${D}${bindir}/find.${PN} | ||
25 | mv ${D}${bindir}/xargs ${D}${bindir}/xargs.${PN} | ||
26 | fi | ||
27 | } | ||
28 | |||
29 | pkg_postinst_${PN} () { | ||
30 | for i in find xargs; do update-alternatives --install ${bindir}/$i $i $i.${PN} 100; done | ||
31 | } | ||
32 | |||
33 | pkg_prerm_${PN} () { | ||
34 | for i in find xargs; do update-alternatives --remove $i $i.${PN}; done | ||
35 | } | ||
36 | |||
37 | BBCLASSEXTEND = "native" | ||