summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool/ethtool_5.4.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-01-20 04:26:43 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-27 16:48:08 +0000
commit54c5b375d17e37ea0f0e8256f39bb056da7ea9c2 (patch)
tree873283db4057cc8a09bd4027a3da7fab33101ef7 /meta/recipes-extended/ethtool/ethtool_5.4.bb
parent5639c150c01fa81ec2897d17ef9e4f8a64da3bdc (diff)
downloadpoky-54c5b375d17e37ea0f0e8256f39bb056da7ea9c2.tar.gz
ethtool: upgrade 5.3 -> 5.4
(From OE-Core rev: 2c51cb945fd3f5874c92d09cc134ed517fa7c435) Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ethtool/ethtool_5.4.bb')
-rw-r--r--meta/recipes-extended/ethtool/ethtool_5.4.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool_5.4.bb b/meta/recipes-extended/ethtool/ethtool_5.4.bb
new file mode 100644
index 0000000000..d6eafaa8dc
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool_5.4.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Display or change ethernet card settings"
2DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
3HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
4SECTION = "console/network"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
8
9SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
10 file://run-ptest \
11 file://avoid_parallel_tests.patch \
12 "
13
14SRC_URI[md5sum] = "fbb24aa414ab9a11ff66d351b5b8493b"
15SRC_URI[sha256sum] = "0b25a46b61bc6e26f56dcb973fc28acea159e2c32c9d6da42c0fa8d1a6339829"
16
17UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/software/network/ethtool/"
18
19inherit autotools ptest bash-completion
20
21RDEPENDS_${PN}-ptest += "make"
22
23do_compile_ptest() {
24 oe_runmake buildtest-TESTS
25}
26
27do_install_ptest () {
28 cp ${B}/Makefile ${D}${PTEST_PATH}
29 install ${B}/test-cmdline ${D}${PTEST_PATH}
30 install ${B}/test-features ${D}${PTEST_PATH}
31 install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
32 sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
33}