summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool/ethtool_5.18.bb
diff options
context:
space:
mode:
authorwangmy <wangmy@fujitsu.com>2022-06-15 16:10:36 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-06-17 17:57:44 +0100
commitcf8124af193bc92ddd9ab3cbe3d4842ee6cadc03 (patch)
treec302b64679149a31a7805d27007ab9e6ba8a29a3 /meta/recipes-extended/ethtool/ethtool_5.18.bb
parentc52bc0734db1696249af48058fa3350b55a4b5f4 (diff)
downloadpoky-cf8124af193bc92ddd9ab3cbe3d4842ee6cadc03.tar.gz
ethtool: upgrade 5.17 -> 5.18
avoid_parallel_tests.patch refresed for new version. (From OE-Core rev: 3302bb98bac31f5df947bdf0a29b065ad77e646e) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ethtool/ethtool_5.18.bb')
-rw-r--r--meta/recipes-extended/ethtool/ethtool_5.18.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool_5.18.bb b/meta/recipes-extended/ethtool/ethtool_5.18.bb
new file mode 100644
index 0000000000..b4f74e7f5b
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool_5.18.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Display or change ethernet card settings"
2DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
3HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
4SECTION = "console/network"
5LICENSE = "GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
8
9SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
10 file://run-ptest \
11 file://avoid_parallel_tests.patch \
12 "
13
14SRC_URI[sha256sum] = "70091f95448eba851f9f9804059d0e237f1d909064046f9e3c6dc892aa1e8afe"
15
16UPSTREAM_CHECK_URI = "https://www.kernel.org/pub/software/network/ethtool/"
17
18inherit autotools ptest bash-completion pkgconfig
19
20RDEPENDS:${PN}-ptest += "make"
21
22PACKAGECONFIG ?= "netlink"
23PACKAGECONFIG[netlink] = "--enable-netlink,--disable-netlink,libmnl,"
24
25do_compile_ptest() {
26 oe_runmake buildtest-TESTS
27}
28
29do_install_ptest () {
30 cp ${B}/Makefile ${D}${PTEST_PATH}
31 install ${B}/test-cmdline ${D}${PTEST_PATH}
32 if ${@bb.utils.contains('PACKAGECONFIG', 'netlink', 'false', 'true', d)}; then
33 install ${B}/test-features ${D}${PTEST_PATH}
34 fi
35 install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
36 sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
37}