summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool/ethtool_4.5.bb
diff options
context:
space:
mode:
authorMaxin B. John <maxin.john@intel.com>2016-05-04 11:20:16 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-11 10:33:38 +0100
commit5a214224a47f0ffee865af267de4a44118429ada (patch)
tree80aed2614cdbe47bc37ae054cd1c24bbe53800c8 /meta/recipes-extended/ethtool/ethtool_4.5.bb
parentdb36fc924666e1905bb76c2f86e1642a67564af5 (diff)
downloadpoky-5a214224a47f0ffee865af267de4a44118429ada.tar.gz
ethtool: upgrade to 4.5
4.2 -> 4.5 (From OE-Core rev: e0e3ec613d5f84ae17a839558b3a3192bd4963ef) Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ethtool/ethtool_4.5.bb')
-rw-r--r--meta/recipes-extended/ethtool/ethtool_4.5.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool_4.5.bb b/meta/recipes-extended/ethtool/ethtool_4.5.bb
new file mode 100644
index 0000000000..c47b30ad79
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool_4.5.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Display or change ethernet card settings"
2DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
3HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
4SECTION = "console/network"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
8
9SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
10 file://run-ptest \
11 file://avoid_parallel_tests.patch \
12 "
13
14SRC_URI[md5sum] = "10038f417db89a1508584d5c375f79bb"
15SRC_URI[sha256sum] = "3b1e69d4de3322e2fe2b1e90befaf2c1ea886469d43ba73af3da36be5e2cc5e7"
16
17inherit autotools ptest
18RDEPENDS_${PN}-ptest += "make"
19
20do_compile_ptest() {
21 oe_runmake buildtest-TESTS
22}
23
24do_install_ptest () {
25 cp ${B}/Makefile ${D}${PTEST_PATH}
26 install ${B}/test-cmdline ${D}${PTEST_PATH}
27 install ${B}/test-features ${D}${PTEST_PATH}
28 install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
29 sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
30}