summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool/ethtool_4.17.bb
diff options
context:
space:
mode:
authorHong Liu <hongl.fnst@cn.fujitsu.com>2018-07-10 10:42:01 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-07-15 16:16:16 +0100
commit46ac750de62fd7cb3bc763db35d187fd7b445f2d (patch)
tree7feaa01a9e928adcca9a3be04d767cc258221840 /meta/recipes-extended/ethtool/ethtool_4.17.bb
parent3c16339f7321ca9476f16f5235974b42b6d6d4ad (diff)
downloadpoky-46ac750de62fd7cb3bc763db35d187fd7b445f2d.tar.gz
ethtool:4.16 -> 4.17
Upgrade ethtool from 4.16 to 4.17 (From OE-Core rev: 11dc07b0d2f3b3c0ff9edc5e6aac3da100cbf588) Signed-off-by: Hong Liu <hongl.fnst@cn.fujitsu.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ethtool/ethtool_4.17.bb')
-rw-r--r--meta/recipes-extended/ethtool/ethtool_4.17.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool_4.17.bb b/meta/recipes-extended/ethtool/ethtool_4.17.bb
new file mode 100644
index 0000000000..844a958ed9
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool_4.17.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Display or change ethernet card settings"
2DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
3HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
4SECTION = "console/network"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
8
9SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
10 file://run-ptest \
11 file://avoid_parallel_tests.patch \
12 "
13
14SRC_URI[md5sum] = "4dba0345a4ab9f51b4a4a9739284238d"
15SRC_URI[sha256sum] = "4130142a15f7409d18de3667998f3c99fba52fd7c8d94be7ecdabf8dcab3d6c1"
16
17inherit autotools ptest
18RDEPENDS_${PN}-ptest += "make"
19
20do_compile_ptest() {
21 oe_runmake buildtest-TESTS
22}
23
24do_install_ptest () {
25 cp ${B}/Makefile ${D}${PTEST_PATH}
26 install ${B}/test-cmdline ${D}${PTEST_PATH}
27 install ${B}/test-features ${D}${PTEST_PATH}
28 install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
29 sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
30}