summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ethtool/ethtool_4.0.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-06-02 02:55:28 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-03 16:38:49 +0100
commit359585a8b67dda54e4b1e3f769d92ed532d3b950 (patch)
tree251d44fc31f9e6ac24b6a8f610c0bc02964586fc /meta/recipes-extended/ethtool/ethtool_4.0.bb
parent46ccf0a8f0c8e1036dc2da17bc68034a2793a160 (diff)
downloadpoky-359585a8b67dda54e4b1e3f769d92ed532d3b950.tar.gz
ethtool: 3.16 -> 4.0
Removed ethtool-uint.patch since it is already in the source. (From OE-Core rev: 0a5bb9f617dffbfddf599555cff5f5536f10b93f) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/ethtool/ethtool_4.0.bb')
-rw-r--r--meta/recipes-extended/ethtool/ethtool_4.0.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/ethtool/ethtool_4.0.bb b/meta/recipes-extended/ethtool/ethtool_4.0.bb
new file mode 100644
index 0000000000..13f2b1cf56
--- /dev/null
+++ b/meta/recipes-extended/ethtool/ethtool_4.0.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Display or change ethernet card settings"
2DESCRIPTION = "A small utility for examining and tuning the settings of your ethernet-based network interfaces."
3HOMEPAGE = "http://www.kernel.org/pub/software/network/ethtool/"
4SECTION = "console/network"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
7 file://ethtool.c;beginline=4;endline=17;md5=c19b30548c582577fc6b443626fc1216"
8
9SRC_URI = "${KERNELORG_MIRROR}/software/network/ethtool/ethtool-${PV}.tar.gz \
10 file://run-ptest \
11 file://avoid_parallel_tests.patch \
12 "
13
14SRC_URI[md5sum] = "0a1c78787c7dcf077016ed86372a472f"
15SRC_URI[sha256sum] = "e200516727cc9583e8b63fd6e72f667f9ed41bb4f0577ff4803b60c64cfd1dbc"
16
17inherit autotools ptest
18RDEPENDS_${PN}-ptest += "make"
19
20do_compile_ptest() {
21 oe_runmake buildtest-TESTS
22}
23
24do_install_ptest () {
25 cp ${B}/Makefile ${D}${PTEST_PATH}
26 install ${B}/test-cmdline ${D}${PTEST_PATH}
27 install ${B}/test-features ${D}${PTEST_PATH}
28 install ${B}/ethtool ${D}${PTEST_PATH}/ethtool
29 sed -i 's/^Makefile/_Makefile/' ${D}${PTEST_PATH}/Makefile
30}