summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/devicekit/devicekit_git.bb
diff options
context:
space:
mode:
authorSaul Wold <Saul.Wold@intel.com>2010-11-22 13:57:13 +0000
committerRichard Purdie <rpurdie@linux.intel.com>2010-11-22 13:57:13 +0000
commitcfe12efb5ec9586dab6961f141d52b103bd8b1d1 (patch)
tree7108e22aa7ddf6cfc2f1b6c6b73a811187706ecb /meta/recipes-extended/devicekit/devicekit_git.bb
parent762fd6b7b3b22d7a8cb80ef9e9ba62e7ef21af3e (diff)
downloadpoky-cfe12efb5ec9586dab6961f141d52b103bd8b1d1.tar.gz
Meta: Recipe Reogranization
This is the next stage of recipe reorganization, in this stage many recipes where moved to a new meta-demoapps layer since this is more appropriate for demo usage then the core. Additional some recipes were moved to meta-extras to indicate they may be depercated at a future time. A number of recipes were modified since dependencies need to be corrected. Signed-off-by: Saul Wold <Saul.Wold@intel.com>
Diffstat (limited to 'meta/recipes-extended/devicekit/devicekit_git.bb')
-rw-r--r--meta/recipes-extended/devicekit/devicekit_git.bb34
1 files changed, 0 insertions, 34 deletions
diff --git a/meta/recipes-extended/devicekit/devicekit_git.bb b/meta/recipes-extended/devicekit/devicekit_git.bb
deleted file mode 100644
index 9845a34d56..0000000000
--- a/meta/recipes-extended/devicekit/devicekit_git.bb
+++ /dev/null
@@ -1,34 +0,0 @@
1LICENSE = "GPL"
2DEPENDS = "dbus-glib"
3
4SRC_URI = "git://anongit.freedesktop.org/DeviceKit/DeviceKit;protocol=git \
5 file://volatile"
6
7PV = "002+git${SRCREV}"
8PR = "r2"
9
10S = "${WORKDIR}/git"
11
12EXTRA_OECONF = "--disable-man-pages"
13
14inherit autotools pkgconfig
15
16do_install_append() {
17 install -d ${D}/etc/default/volatiles
18 install -m 0644 ${WORKDIR}/volatile ${D}/etc/default/volatiles/devicekit
19}
20
21pkg_postinst_devicekit () {
22 # can't do this offline
23 if [ "x$D" != "x" ]; then
24 exit 1
25 fi
26
27 DBUSPID=`pidof dbus-daemon`
28
29 if [ "x$DBUSPID" != "x" ]; then
30 /etc/init.d/dbus-1 reload
31 fi
32}
33
34FILES_${PN} += "${datadir}/dbus-1/"