summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/cronie/cronie_1.7.2.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-04-24 16:41:56 +0800
committerSteve Sakoman <steve@sakoman.com>2024-06-19 08:34:57 -0700
commit7fbd3442cead1f0abbb2d44f9e7e2639b2ce8def (patch)
tree975097891fbd6a37dda8f912ef4659c997574877 /meta/recipes-extended/cronie/cronie_1.7.2.bb
parent0efe15c5ba29ba4d8599b5d151e6e8ffbf9b253d (diff)
downloadpoky-7fbd3442cead1f0abbb2d44f9e7e2639b2ce8def.tar.gz
cronie: upgrade 1.7.1 -> 1.7.2
Changelog: ============ *Revert setting the return path to <>. It is not RFC compliant. *Inherit MAILFROM from the crond process environment. (From OE-Core rev: c33261bbf0193f7f73c57ec8c463ecc36799991e) Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit e93d7ba7ea3718e396510b12726a232edaecf976) Signed-off-by: Steve Sakoman <steve@sakoman.com>
Diffstat (limited to 'meta/recipes-extended/cronie/cronie_1.7.2.bb')
-rw-r--r--meta/recipes-extended/cronie/cronie_1.7.2.bb85
1 files changed, 85 insertions, 0 deletions
diff --git a/meta/recipes-extended/cronie/cronie_1.7.2.bb b/meta/recipes-extended/cronie/cronie_1.7.2.bb
new file mode 100644
index 0000000000..abdaff644d
--- /dev/null
+++ b/meta/recipes-extended/cronie/cronie_1.7.2.bb
@@ -0,0 +1,85 @@
1SUMMARY = "Cron daemon for executing programs at set times"
2DESCRIPTION = "Cronie contains the standard UNIX daemon crond that runs \
3specified programs at scheduled times and related tools. It is based on the \
4original cron and has security and configuration enhancements like the \
5ability to use pam and SELinux."
6HOMEPAGE = "https://github.com/cronie-crond/cronie/"
7BUGTRACKER = "https://bugzilla.redhat.com"
8
9# Internet Systems Consortium License
10LICENSE = "ISC & BSD-3-Clause & BSD-2-Clause & GPL-2.0-or-later"
11LIC_FILES_CHKSUM = "file://COPYING;md5=dd2a592170760e1386c769e1043b3722 \
12 file://src/cron.c;endline=20;md5=b425c334265026177128353a142633b4 \
13 file://src/popen.c;beginline=3;endline=31;md5=edd50742d8def712e9472dba353668a9"
14
15SECTION = "utils"
16
17GITHUB_BASE_URI = "https://github.com/cronie-crond/${BPN}/releases/"
18
19SRC_URI = "${GITHUB_BASE_URI}/download/cronie-${PV}/cronie-${PV}.tar.gz \
20 file://crond.init \
21 file://crontab \
22 file://crond.service \
23 ${@bb.utils.contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}"
24
25PAM_SRC_URI = "file://crond_pam_config.patch"
26PAM_DEPS = "libpam libpam-runtime pam-plugin-access pam-plugin-loginuid"
27
28SRC_URI[sha256sum] = "f1da374a15ba7605cf378347f96bc8b678d3d7c0765269c8242cfe5b0789c571"
29
30inherit autotools update-rc.d useradd systemd github-releases
31UPSTREAM_CHECK_REGEX = "releases/tag/cronie-(?P<pver>\d+(\.\d+)+)"
32
33PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'pam', d)}"
34
35PACKAGECONFIG[audit] = "--with-audit,--without-audit,audit,"
36PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam,${PAM_DEPS}"
37PACKAGECONFIG[anacron] = "--enable-anacron,--disable-anacron,anacron"
38PACKAGECONFIG[selinux] = "--with-selinux,--without-selinux,libselinux"
39
40INITSCRIPT_NAME = "crond"
41INITSCRIPT_PARAMS = "start 90 2 3 4 5 . stop 60 0 1 6 ."
42
43USERADD_PACKAGES = "${PN}"
44GROUPADD_PARAM:${PN} = "--system crontab"
45
46SYSTEMD_SERVICE:${PN} = "crond.service"
47
48do_install:append () {
49 install -d ${D}${sysconfdir}/sysconfig/
50 install -d ${D}${sysconfdir}/init.d/
51 install -m 0644 ${S}/crond.sysconfig ${D}${sysconfdir}/sysconfig/crond
52 install -m 0755 ${WORKDIR}/crond.init ${D}${sysconfdir}/init.d/crond
53
54 # install systemd unit files
55 install -d ${D}${systemd_system_unitdir}
56 install -m 0644 ${WORKDIR}/crond.service ${D}${systemd_system_unitdir}
57 sed -i -e 's,@BASE_BINDIR@,${base_bindir},g' \
58 -e 's,@SBINDIR@,${sbindir},g' \
59 ${D}${systemd_system_unitdir}/crond.service
60
61 # below are necessary for a complete cron environment
62 install -d ${D}${localstatedir}/spool/cron
63 install -m 0755 ${WORKDIR}/crontab ${D}${sysconfdir}/
64 mkdir -p ${D}${sysconfdir}/cron.d
65 mkdir -p ${D}${sysconfdir}/cron.hourly
66 mkdir -p ${D}${sysconfdir}/cron.daily
67 mkdir -p ${D}${sysconfdir}/cron.weekly
68 mkdir -p ${D}${sysconfdir}/cron.monthly
69 touch ${D}${sysconfdir}/cron.deny
70
71 # below setting is necessary to allow normal user using crontab
72
73 # setgid for crontab binary
74 chown root:crontab ${D}${bindir}/crontab
75 chmod 2755 ${D}${bindir}/crontab
76
77 # allow 'crontab' group write to /var/spool/cron
78 chown root:crontab ${D}${localstatedir}/spool/cron
79 chmod 770 ${D}${localstatedir}/spool/cron
80
81 chmod 600 ${D}${sysconfdir}/crontab
82}
83
84FILES:${PN} += "${sysconfdir}/cron*"
85CONFFILES:${PN} += "${sysconfdir}/crontab"