diff options
author | Cristiana Voicu <cristiana.voicu@intel.com> | 2013-08-16 11:30:49 +0300 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2013-08-16 11:44:15 +0100 |
commit | de9614711b243d0fb239e08c8c202a228aa63946 (patch) | |
tree | 235b13d610c9078637b678f5b81d1594cbc2823a /meta/recipes-extended/cronie/cronie_1.4.11.bb | |
parent | 660601bd9710a37c544131201eb9fa10a08a9de3 (diff) | |
download | poky-de9614711b243d0fb239e08c8c202a228aa63946.tar.gz |
cronie: upgrade to 1.4.11
LIC_FILES_CHKSUM changed because cron.h doesn't exist anymore.
Replaced it with cron.c.
(From OE-Core rev: c1f3eabece0bb998c46367c06e3433696f97225c)
Signed-off-by: Cristiana Voicu <cristiana.voicu@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/cronie/cronie_1.4.11.bb')
-rw-r--r-- | meta/recipes-extended/cronie/cronie_1.4.11.bb | 73 |
1 files changed, 73 insertions, 0 deletions
diff --git a/meta/recipes-extended/cronie/cronie_1.4.11.bb b/meta/recipes-extended/cronie/cronie_1.4.11.bb new file mode 100644 index 0000000000..5b124482a3 --- /dev/null +++ b/meta/recipes-extended/cronie/cronie_1.4.11.bb | |||
@@ -0,0 +1,73 @@ | |||
1 | SUMMARY = "Cron daemon for executing programs at set times" | ||
2 | DESCRIPTION = "Cronie contains the standard UNIX daemon crond that runs \ | ||
3 | specified programs at scheduled times and related tools. It is based on the \ | ||
4 | original cron and has security and configuration enhancements like the \ | ||
5 | ability to use pam and SELinux." | ||
6 | HOMEPAGE = "https://fedorahosted.org/cronie/" | ||
7 | BUGTRACKER = "mmaslano@redhat.com" | ||
8 | |||
9 | # Internet Systems Consortium License | ||
10 | LICENSE = "ISC & BSD" | ||
11 | LIC_FILES_CHKSUM = "file://COPYING;md5=963ea0772a2adbdcd607a9b2ec320c11 \ | ||
12 | file://src/cron.c;endline=20;md5=b425c334265026177128353a142633b4 \ | ||
13 | file://src/popen.c;beginline=3;endline=31;md5=edd50742d8def712e9472dba353668a9" | ||
14 | |||
15 | SECTION = "utils" | ||
16 | |||
17 | DEPENDS += "${@base_contains('DISTRO_FEATURES', 'pam', 'libpam', '', d)}" | ||
18 | RDEPENDS_${PN} = "${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_DEPS}', '', d)}" | ||
19 | PAM_DEPS = "libpam libpam-runtime pam-plugin-access pam-plugin-loginuid" | ||
20 | |||
21 | SRC_URI = "https://fedorahosted.org/releases/c/r/cronie/cronie-${PV}.tar.gz \ | ||
22 | file://crond.init \ | ||
23 | file://crontab \ | ||
24 | ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}" | ||
25 | |||
26 | PAM_SRC_URI = "file://crond_pam_config.patch" | ||
27 | |||
28 | |||
29 | SRC_URI[md5sum] = "2ba645cf54de17f138ef70312843862f" | ||
30 | SRC_URI[sha256sum] = "fd08084cedddbb42499f80ddb7f2158195c3555c2ff40ee11d4ece2f9864d7be" | ||
31 | |||
32 | inherit autotools update-rc.d useradd | ||
33 | |||
34 | EXTRA_OECONF += "\ | ||
35 | ${@base_contains('DISTRO_FEATURES', 'pam', '--with-pam', '--without-pam', d)}" | ||
36 | |||
37 | INITSCRIPT_NAME = "crond" | ||
38 | INITSCRIPT_PARAMS = "start 90 2 3 4 5 . stop 60 0 1 6 ." | ||
39 | |||
40 | USERADD_PACKAGES = "${PN}" | ||
41 | GROUPADD_PARAM_${PN} = "--system crontab" | ||
42 | |||
43 | do_install_append () { | ||
44 | install -d ${D}${sysconfdir}/sysconfig/ | ||
45 | install -d ${D}${sysconfdir}/init.d/ | ||
46 | install -m 0644 ${S}/crond.sysconfig ${D}${sysconfdir}/sysconfig/crond | ||
47 | install -m 0755 ${WORKDIR}/crond.init ${D}${sysconfdir}/init.d/crond | ||
48 | |||
49 | # below are necessary for a complete cron environment | ||
50 | install -d ${D}${localstatedir}/spool/cron | ||
51 | install -m 0755 ${WORKDIR}/crontab ${D}${sysconfdir}/ | ||
52 | mkdir -p ${D}${sysconfdir}/cron.d | ||
53 | mkdir -p ${D}${sysconfdir}/cron.hourly | ||
54 | mkdir -p ${D}${sysconfdir}/cron.daily | ||
55 | mkdir -p ${D}${sysconfdir}/cron.weekly | ||
56 | mkdir -p ${D}${sysconfdir}/cron.monthly | ||
57 | touch ${D}${sysconfdir}/cron.deny | ||
58 | |||
59 | # below setting is necessary to allow normal user using crontab | ||
60 | |||
61 | # setgid for crontab binary | ||
62 | chown root:crontab ${D}${bindir}/crontab | ||
63 | chmod 2755 ${D}${bindir}/crontab | ||
64 | |||
65 | # allow 'crontab' group write to /var/spool/cron | ||
66 | chown root:crontab ${D}${localstatedir}/spool/cron | ||
67 | chmod 770 ${D}${localstatedir}/spool/cron | ||
68 | |||
69 | chmod 600 ${D}${sysconfdir}/crontab | ||
70 | } | ||
71 | |||
72 | FILES_${PN} += "${sysconfdir}/cron*" | ||
73 | |||