summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/cronie/cronie_1.4.11.bb
diff options
context:
space:
mode:
authorAdrian Dudau <adrian.dudau@enea.com>2014-06-26 14:36:22 +0200
committerAdrian Dudau <adrian.dudau@enea.com>2014-06-26 15:32:53 +0200
commitf4cf9fe05bb3f32fabea4e54dd92d368967a80da (patch)
tree487180fa9866985ea7b28e625651765d86f515c3 /meta/recipes-extended/cronie/cronie_1.4.11.bb
downloadpoky-f4cf9fe05bb3f32fabea4e54dd92d368967a80da.tar.gz
initial commit for Enea Linux 4.0
Migrated from the internal git server on the daisy-enea branch Signed-off-by: Adrian Dudau <adrian.dudau@enea.com>
Diffstat (limited to 'meta/recipes-extended/cronie/cronie_1.4.11.bb')
-rw-r--r--meta/recipes-extended/cronie/cronie_1.4.11.bb75
1 files changed, 75 insertions, 0 deletions
diff --git a/meta/recipes-extended/cronie/cronie_1.4.11.bb b/meta/recipes-extended/cronie/cronie_1.4.11.bb
new file mode 100644
index 0000000000..d98d0d9167
--- /dev/null
+++ b/meta/recipes-extended/cronie/cronie_1.4.11.bb
@@ -0,0 +1,75 @@
1SUMMARY = "Cron daemon for executing programs at set times"
2DESCRIPTION = "Cronie contains the standard UNIX daemon crond that runs \
3specified programs at scheduled times and related tools. It is based on the \
4original cron and has security and configuration enhancements like the \
5ability to use pam and SELinux."
6HOMEPAGE = "https://fedorahosted.org/cronie/"
7BUGTRACKER = "mmaslano@redhat.com"
8
9# Internet Systems Consortium License
10LICENSE = "ISC & BSD"
11LIC_FILES_CHKSUM = "file://COPYING;md5=963ea0772a2adbdcd607a9b2ec320c11 \
12 file://src/cron.c;endline=20;md5=b425c334265026177128353a142633b4 \
13 file://src/popen.c;beginline=3;endline=31;md5=edd50742d8def712e9472dba353668a9"
14
15SECTION = "utils"
16
17
18SRC_URI = "https://fedorahosted.org/releases/c/r/cronie/cronie-${PV}.tar.gz \
19 file://fix-out-of-tree-build.patch \
20 file://crond.init \
21 file://crontab \
22 ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)}"
23
24PAM_SRC_URI = "file://crond_pam_config.patch"
25PAM_DEPS = "libpam libpam-runtime pam-plugin-access pam-plugin-loginuid"
26
27SRC_URI[md5sum] = "2ba645cf54de17f138ef70312843862f"
28SRC_URI[sha256sum] = "fd08084cedddbb42499f80ddb7f2158195c3555c2ff40ee11d4ece2f9864d7be"
29
30inherit autotools update-rc.d useradd
31
32
33PACKAGECONFIG ?= "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)}"
34
35PACKAGECONFIG[audit] = "--with-audit,--without-audit,audit,"
36PACKAGECONFIG[pam] = "--with-pam,--without-pam,libpam,${PAM_DEPS}"
37
38
39INITSCRIPT_NAME = "crond"
40INITSCRIPT_PARAMS = "start 90 2 3 4 5 . stop 60 0 1 6 ."
41
42USERADD_PACKAGES = "${PN}"
43GROUPADD_PARAM_${PN} = "--system crontab"
44
45do_install_append () {
46 install -d ${D}${sysconfdir}/sysconfig/
47 install -d ${D}${sysconfdir}/init.d/
48 install -m 0644 ${S}/crond.sysconfig ${D}${sysconfdir}/sysconfig/crond
49 install -m 0755 ${WORKDIR}/crond.init ${D}${sysconfdir}/init.d/crond
50
51 # below are necessary for a complete cron environment
52 install -d ${D}${localstatedir}/spool/cron
53 install -m 0755 ${WORKDIR}/crontab ${D}${sysconfdir}/
54 mkdir -p ${D}${sysconfdir}/cron.d
55 mkdir -p ${D}${sysconfdir}/cron.hourly
56 mkdir -p ${D}${sysconfdir}/cron.daily
57 mkdir -p ${D}${sysconfdir}/cron.weekly
58 mkdir -p ${D}${sysconfdir}/cron.monthly
59 touch ${D}${sysconfdir}/cron.deny
60
61 # below setting is necessary to allow normal user using crontab
62
63 # setgid for crontab binary
64 chown root:crontab ${D}${bindir}/crontab
65 chmod 2755 ${D}${bindir}/crontab
66
67 # allow 'crontab' group write to /var/spool/cron
68 chown root:crontab ${D}${localstatedir}/spool/cron
69 chmod 770 ${D}${localstatedir}/spool/cron
70
71 chmod 600 ${D}${sysconfdir}/crontab
72}
73
74FILES_${PN} += "${sysconfdir}/cron*"
75