diff options
author | Robert Yang <liezhi.yang@windriver.com> | 2015-07-27 02:09:23 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2015-07-31 10:32:42 +0100 |
commit | 45efeffcf4808fc6d9bfbb60ae17f02c936e31dd (patch) | |
tree | f9f0a6a6de993a512cf27ec1cee07a62b603d7c4 /meta/recipes-extended/cracklib/cracklib_2.9.5.bb | |
parent | 2b9dca169d9ea1220ffdc47b5ddecd3d02549887 (diff) | |
download | poky-45efeffcf4808fc6d9bfbb60ae17f02c936e31dd.tar.gz |
cracklib: 2.9.4 -> 2.9.5
(From OE-Core rev: 466dcc8358f3bd041854084fc6c0eb55a830342f)
Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/cracklib/cracklib_2.9.5.bb')
-rw-r--r-- | meta/recipes-extended/cracklib/cracklib_2.9.5.bb | 45 |
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-extended/cracklib/cracklib_2.9.5.bb b/meta/recipes-extended/cracklib/cracklib_2.9.5.bb new file mode 100644 index 0000000000..c0ffe33160 --- /dev/null +++ b/meta/recipes-extended/cracklib/cracklib_2.9.5.bb | |||
@@ -0,0 +1,45 @@ | |||
1 | SUMMARY = "Password strength checker library" | ||
2 | HOMEPAGE = "http://sourceforge.net/projects/cracklib" | ||
3 | |||
4 | LICENSE = "LGPLv2.1+" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=e3eda01d9815f8d24aae2dbd89b68b06" | ||
6 | |||
7 | DEPENDS = "cracklib-native zlib python" | ||
8 | RDEPEND_${PN}-python += "python" | ||
9 | |||
10 | PACKAGES += "${PN}-python" | ||
11 | |||
12 | EXTRA_OECONF = "--with-python --libdir=${base_libdir}" | ||
13 | |||
14 | SRC_URI = "${SOURCEFORGE_MIRROR}/cracklib/cracklib-${PV}.tar.gz \ | ||
15 | file://0001-packlib.c-support-dictionary-byte-order-dependent.patch \ | ||
16 | file://0002-craklib-fix-testnum-and-teststr-failed.patch" | ||
17 | |||
18 | SRC_URI[md5sum] = "376790a95c1fb645e59e6e9803c78582" | ||
19 | SRC_URI[sha256sum] = "59ab0138bc8cf90cccb8509b6969a024d5e58d2d02bcbdccbb9ba9b88be3fa33" | ||
20 | |||
21 | inherit autotools gettext pythonnative python-dir | ||
22 | |||
23 | do_install_append_class-target() { | ||
24 | create-cracklib-dict -o ${D}${datadir}/cracklib/pw_dict ${D}${datadir}/cracklib/cracklib-small | ||
25 | } | ||
26 | |||
27 | do_install_append() { | ||
28 | src_dir="${D}${base_libdir}/${PYTHON_DIR}/site-packages" | ||
29 | rm -f $src_dir/*.pyo | ||
30 | rm -f $src_dir/test_cracklib.py | ||
31 | # Move python files from ${base_libdir} to ${libdir} since used --libdir=${base_libdir} | ||
32 | install -d -m 0755 ${D}${PYTHON_SITEPACKAGES_DIR}/ | ||
33 | mv $src_dir/* ${D}${PYTHON_SITEPACKAGES_DIR} | ||
34 | rm -fr ${D}${base_libdir}/${PYTHON_DIR} | ||
35 | } | ||
36 | |||
37 | BBCLASSEXTEND = "native nativesdk" | ||
38 | |||
39 | FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}/cracklib.py \ | ||
40 | ${PYTHON_SITEPACKAGES_DIR}/_cracklib.so \ | ||
41 | " | ||
42 | FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug/_cracklib.so" | ||
43 | FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/_cracklib.a \ | ||
44 | ${PYTHON_SITEPACKAGES_DIR}/_cracklib.la \ | ||
45 | " | ||