summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bzip2/bzip2_1.0.5.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:11 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-01 19:09:57 +0100
commitd62ee7eaf2ba025c3f64b2d4e10dc7cec4637612 (patch)
treef36fe3008f36ff75cbdd31b630f8f13f1f205ebb /meta/recipes-extended/bzip2/bzip2_1.0.5.bb
parentcaab7fc509bf27706ff3248689f6afd04225cfda (diff)
downloadpoky-d62ee7eaf2ba025c3f64b2d4e10dc7cec4637612.tar.gz
packages: Separate out most of the remaining packages into recipes
Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-extended/bzip2/bzip2_1.0.5.bb')
-rw-r--r--meta/recipes-extended/bzip2/bzip2_1.0.5.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-extended/bzip2/bzip2_1.0.5.bb b/meta/recipes-extended/bzip2/bzip2_1.0.5.bb
new file mode 100644
index 0000000000..c6339c0676
--- /dev/null
+++ b/meta/recipes-extended/bzip2/bzip2_1.0.5.bb
@@ -0,0 +1,41 @@
1DESCRIPTION = "Very high-quality data compression program."
2HOMEPAGE = "http://www.bzip.org/"
3SECTION = "console/utils"
4LICENSE = "bzip2"
5LIC_FILES_CHKSUM = "file://LICENSE;beginline=8;endline=37;md5=40d9d1eb05736d1bfc86cfdd9106e6b2"
6PR = "r2"
7
8SRC_URI = "http://www.bzip.org/${PV}/${BPN}-${PV}.tar.gz \
9 file://configure.ac \
10 file://Makefile.am"
11
12CFLAGS_append = " -fPIC -fpic -Winline -fno-strength-reduce -D_FILE_OFFSET_BITS=64"
13
14inherit autotools
15
16do_configure_prepend () {
17 cp ${WORKDIR}/configure.ac ${S}/
18 cp ${WORKDIR}/Makefile.am ${S}/
19 cp ${STAGING_DATADIR_NATIVE}/automake*/install-sh ${S}/
20}
21
22do_install_append () {
23 if [ "${BUILD_ARCH}" != "${HOST_ARCH}" ]; then
24 mv ${D}${bindir}/bunzip2 ${D}${bindir}/bunzip2.${PN}
25 mv ${D}${bindir}/bzcat ${D}${bindir}/bzcat.${PN}
26 fi
27}
28
29pkg_postinst_${PN} () {
30 update-alternatives --install ${bindir}/bunzip2 bunzip2 bunzip2.${PN} 100
31 update-alternatives --install ${bindir}/bzcat bzcat bzcat.${PN} 100
32}
33
34
35pkg_prerm_${PN} () {
36 update-alternatives --remove bunzip2 bunzip2.${PN}
37 update-alternatives --remove bzcat bzcat.${PN}
38}
39
40PROVIDES_append_virtclass-native = " bzip2-full-native"
41BBCLASSEXTEND = "native"