summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bash/bash_5.0.bb
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2019-05-12 16:16:24 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-12 17:55:11 +0100
commit777b33a77cc357dfe8c3adc3cd952dcd53cd8976 (patch)
treef22104d9d6467ea1e7108548b6774bc317a5cced /meta/recipes-extended/bash/bash_5.0.bb
parent217d4d5660976ecc79aaf919ecaaedd080023f7d (diff)
downloadpoky-777b33a77cc357dfe8c3adc3cd952dcd53cd8976.tar.gz
bash: upgrade 4.4.18 -> 5.0
- Rebase build-tests.patch and execute_cmd.patch to 5.0 - Drop 0001-help-fix-printf-format-security-warning.patch and pathexp-dep.patch, upstream has fixed them in commit [d233b48 bash-5.0 distribution sources and documentation] (From OE-Core rev: db044235e72a1519a081c4f6541f7d7cfe70d49f) Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/bash/bash_5.0.bb')
-rw-r--r--meta/recipes-extended/bash/bash_5.0.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-extended/bash/bash_5.0.bb b/meta/recipes-extended/bash/bash_5.0.bb
new file mode 100644
index 0000000000..e60e5304a5
--- /dev/null
+++ b/meta/recipes-extended/bash/bash_5.0.bb
@@ -0,0 +1,45 @@
1require bash.inc
2
3# GPLv2+ (< 4.0), GPLv3+ (>= 4.0)
4LICENSE = "GPLv3+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6
7SRC_URI = "${GNU_MIRROR}/bash/${BP}.tar.gz;name=tarball \
8 ${GNU_MIRROR}/bash/bash-${PV}-patches/bash50-001;apply=yes;striplevel=0;name=patch001 \
9 ${GNU_MIRROR}/bash/bash-${PV}-patches/bash50-002;apply=yes;striplevel=0;name=patch002 \
10 ${GNU_MIRROR}/bash/bash-${PV}-patches/bash50-003;apply=yes;striplevel=0;name=patch003 \
11 ${GNU_MIRROR}/bash/bash-${PV}-patches/bash50-004;apply=yes;striplevel=0;name=patch004 \
12 ${GNU_MIRROR}/bash/bash-${PV}-patches/bash50-005;apply=yes;striplevel=0;name=patch005 \
13 ${GNU_MIRROR}/bash/bash-${PV}-patches/bash50-006;apply=yes;striplevel=0;name=patch006 \
14 ${GNU_MIRROR}/bash/bash-${PV}-patches/bash50-007;apply=yes;striplevel=0;name=patch007 \
15 file://execute_cmd.patch \
16 file://mkbuiltins_have_stringize.patch \
17 file://build-tests.patch \
18 file://test-output.patch \
19 file://fix-run-coproc-run-heredoc-run-execscript-run-test-f.patch \
20 file://run-ptest \
21 file://fix-run-builtins.patch \
22 "
23
24SRC_URI[tarball.md5sum] = "2b44b47b905be16f45709648f671820b"
25SRC_URI[tarball.sha256sum] = "b4a80f2ac66170b2913efbfb9f2594f1f76c7b1afd11f799e22035d63077fb4d"
26
27SRC_URI[patch001.md5sum] = "b026862ab596a5883bb4f0d1077a3819"
28SRC_URI[patch001.sha256sum] = "f2fe9e1f0faddf14ab9bfa88d450a75e5d028fedafad23b88716bd657c737289"
29SRC_URI[patch002.md5sum] = "2f4a7787365790ae57f36b311701ea7e"
30SRC_URI[patch002.sha256sum] = "87e87d3542e598799adb3e7e01c8165bc743e136a400ed0de015845f7ff68707"
31SRC_URI[patch003.md5sum] = "af7f2dd93fd5429fb5e9a642ff74f87d"
32SRC_URI[patch003.sha256sum] = "4eebcdc37b13793a232c5f2f498a5fcbf7da0ecb3da2059391c096db620ec85b"
33SRC_URI[patch004.md5sum] = "b60545b273bfa4e00a760f2c648bed9c"
34SRC_URI[patch004.sha256sum] = "14447ad832add8ecfafdce5384badd933697b559c4688d6b9e3d36ff36c62f08"
35SRC_URI[patch005.md5sum] = "875a0bedf48b74e453e3997c84b5d8a4"
36SRC_URI[patch005.sha256sum] = "5bf54dd9bd2c211d2bfb34a49e2c741f2ed5e338767e9ce9f4d41254bf9f8276"
37SRC_URI[patch006.md5sum] = "4a8ee95adb72c3aba03d9e8c9f96ece6"
38SRC_URI[patch006.sha256sum] = "d68529a6ff201b6ff5915318ab12fc16b8a0ebb77fda3308303fcc1e13398420"
39SRC_URI[patch007.md5sum] = "411560d81fde2dc5b17b83c3f3b58c6f"
40SRC_URI[patch007.sha256sum] = "17b41e7ee3673d8887dd25992417a398677533ab8827938aa41fad70df19af9b"
41
42DEBUG_OPTIMIZATION_append_armv4 = " ${@bb.utils.contains('TUNE_CCARGS', '-mthumb', '-fomit-frame-pointer', '', d)}"
43DEBUG_OPTIMIZATION_append_armv5 = " ${@bb.utils.contains('TUNE_CCARGS', '-mthumb', '-fomit-frame-pointer', '', d)}"
44
45BBCLASSEXTEND = "nativesdk"