diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2018-08-05 19:40:57 +0000 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2018-08-08 10:52:00 +0100 |
commit | 3f434923909bd21c9497ee883bd2f5286f64f473 (patch) | |
tree | 777b79ddde4a20238417a8af85223ef807ffb130 /meta/recipes-extended/bash/bash_4.4.18.bb | |
parent | e77d45609a08d2c61964fbb092b1a21f11310f3b (diff) | |
download | poky-3f434923909bd21c9497ee883bd2f5286f64f473.tar.gz |
bash: add -fomit-frame-pointer to DEBUG_OPTIMIZATION for armv[45] with thumb enabled
with thumb and debug enabled bash gets stuck forever when building for qemuarm.
bash/4.4.18-r0/build/builtins$ arm-webos-linux-gnueabi-gcc -march=armv5te -mthumb -fstack-protector-strong --sysroot=bash/4.4.18-r0/recipe-sysroot -c -DHAVE_CONFIG_H -DSHELL -I. -I.. -I../../bash-4.4.18 -I../../bash-4.4.18/include -I../../bash-4.4.18/lib -I../../bash-4.4.18/builtins -O -fno-omit-frame-pointer -g -DNON_INTERACTIVE_LOGIN_SHELLS read.c
when -mthumb, -fstack-protector-strong, -fno-omit-frame-pointer appear
together, removing one of them is enough for successful build.
similar to:
http://lists.openembedded.org/pipermail/openembedded-core/2018-May/150654.html
but in this case the build gets stuck instead of failure
(From OE-Core rev: ae41e1f263d20d5d83b2a7ca95dc955840d793e1)
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/bash/bash_4.4.18.bb')
-rw-r--r-- | meta/recipes-extended/bash/bash_4.4.18.bb | 3 |
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-extended/bash/bash_4.4.18.bb b/meta/recipes-extended/bash/bash_4.4.18.bb index 0b22ca7a69..b338acd9dc 100644 --- a/meta/recipes-extended/bash/bash_4.4.18.bb +++ b/meta/recipes-extended/bash/bash_4.4.18.bb | |||
@@ -19,4 +19,7 @@ SRC_URI = "${GNU_MIRROR}/bash/${BP}.tar.gz;name=tarball \ | |||
19 | SRC_URI[tarball.md5sum] = "518e2c187cc11a17040f0915dddce54e" | 19 | SRC_URI[tarball.md5sum] = "518e2c187cc11a17040f0915dddce54e" |
20 | SRC_URI[tarball.sha256sum] = "604d9eec5e4ed5fd2180ee44dd756ddca92e0b6aa4217bbab2b6227380317f23" | 20 | SRC_URI[tarball.sha256sum] = "604d9eec5e4ed5fd2180ee44dd756ddca92e0b6aa4217bbab2b6227380317f23" |
21 | 21 | ||
22 | DEBUG_OPTIMIZATION_append_armv4 = " ${@bb.utils.contains('TUNE_CCARGS', '-mthumb', '-fomit-frame-pointer', '', d)}" | ||
23 | DEBUG_OPTIMIZATION_append_armv5 = " ${@bb.utils.contains('TUNE_CCARGS', '-mthumb', '-fomit-frame-pointer', '', d)}" | ||
24 | |||
22 | BBCLASSEXTEND = "nativesdk" | 25 | BBCLASSEXTEND = "nativesdk" |