summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bash/bash_4.3.30.bb
diff options
context:
space:
mode:
authorDengke Du <dengke.du@windriver.com>2016-08-17 23:10:57 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-23 17:44:38 +0100
commitddaf84ce8640034e028d794131d88a2453ab0bc9 (patch)
tree4ab7937e0a9fd08cce5d73fce7f9b197aca874ef /meta/recipes-extended/bash/bash_4.3.30.bb
parent0db6b0f363c9bf6fc36ceb933f10196b131d3b18 (diff)
downloadpoky-ddaf84ce8640034e028d794131d88a2453ab0bc9.tar.gz
bash: fix run-intl ptest failed
1. Filter the extra white space in intl.right When the sub-test unicode2.sub of intl.tests executed, it produced compact results without extra white space, compared to intl.right, it failed. So we need to filter the extra white space in intl.right. Import this patch for intl.right from bash devel branch: http://git.savannah.gnu.org/cgit/bash.git/log/?h=devel Commit is: 85ec0778f9d778e1820fb8c0e3e996f2d1103b45 2. Change intl.right correspond to the unicode3.sub's output In sub-test unicode3.sub of intl.tests have this: printf %q "$payload" The payload variable was assigned by ASCII characters, when using '%q' format strings, it means print the associated argument shell-quoted. When the strings contain the non-alpha && non-digit && non-punctuation && non-ISO 646 character(7-bit), it would output like this: " $'...', ANSI-C style quoted string. We can check the bash source code at: http://git.savannah.gnu.org/cgit/bash.git/tree/builtins/printf.def#n557 http://git.savannah.gnu.org/cgit/bash.git/tree/lib/sh/strtrans.c#n331 So we need to change the intl.right contain the correct output of unicode3.sub. Import parts of this patch for intl.right from bash devel branch: http://git.savannah.gnu.org/cgit/bash.git/log/?h=devel Commit is: 74b8cbb41398b4453d8ba04d0cdd1b25f9dcb9e3 3. Add the sanity check for locales When run the intl.tests, we need the following locales: en_US & fr_FR & de_DE So add the locales check for the intl.tests in run-ptest. (From OE-Core rev: 640676226bb351420a0a8b2d2a3c120ae42da11e) Signed-off-by: Dengke Du <dengke.du@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/bash/bash_4.3.30.bb')
-rw-r--r--meta/recipes-extended/bash/bash_4.3.30.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-extended/bash/bash_4.3.30.bb b/meta/recipes-extended/bash/bash_4.3.30.bb
index 79efaed3d1..765562fbdd 100644
--- a/meta/recipes-extended/bash/bash_4.3.30.bb
+++ b/meta/recipes-extended/bash/bash_4.3.30.bb
@@ -27,8 +27,9 @@ SRC_URI = "${GNU_MIRROR}/bash/${BP}.tar.gz;name=tarball \
27 file://test-output.patch \ 27 file://test-output.patch \
28 file://fix-run-coproc-run-heredoc-run-execscript-run-test-f.patch \ 28 file://fix-run-coproc-run-heredoc-run-execscript-run-test-f.patch \
29 file://run-ptest \ 29 file://run-ptest \
30 file://fix-run-builtins.patch \ 30 file://fix-run-builtins.patch \
31 file://0001-help-fix-printf-format-security-warning.patch \ 31 file://0001-help-fix-printf-format-security-warning.patch \
32 file://fix-run-intl.patch \
32 " 33 "
33 34
34SRC_URI[tarball.md5sum] = "a27b3ee9be83bd3ba448c0ff52b28447" 35SRC_URI[tarball.md5sum] = "a27b3ee9be83bd3ba448c0ff52b28447"