summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/bash/bash_4.3.30.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-08-03 08:44:22 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-10 12:40:21 -0700
commit44bbb402af75c78eb7dc25e7374ccfcfa7410034 (patch)
treef63015fa303c8a7ea8765d4f4466bc37eb3a4dfd /meta/recipes-extended/bash/bash_4.3.30.bb
parent280a8954fbe9d7fc082e53d55cefaac34c728abe (diff)
downloadpoky-44bbb402af75c78eb7dc25e7374ccfcfa7410034.tar.gz
bash: 4.3 -> 4.3.30
Remove patch001 -> patch030 since they are already in source, add patch031 -> patch039 (From OE-Core rev: 781ec1061306f43265f9d756a89d1b86bd5d19a0) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/bash/bash_4.3.30.bb')
-rw-r--r--meta/recipes-extended/bash/bash_4.3.30.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-extended/bash/bash_4.3.30.bb b/meta/recipes-extended/bash/bash_4.3.30.bb
new file mode 100644
index 0000000000..811e61c798
--- /dev/null
+++ b/meta/recipes-extended/bash/bash_4.3.30.bb
@@ -0,0 +1,46 @@
1require bash.inc
2
3# GPLv2+ (< 4.0), GPLv3+ (>= 4.0)
4LICENSE = "GPLv3+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6
7SRC_URI = "${GNU_MIRROR}/bash/${BP}.tar.gz;name=tarball \
8 ${GNU_MIRROR}/bash/bash-4.3-patches/bash43-031;apply=yes;striplevel=0;name=patch031 \
9 ${GNU_MIRROR}/bash/bash-4.3-patches/bash43-032;apply=yes;striplevel=0;name=patch032 \
10 ${GNU_MIRROR}/bash/bash-4.3-patches/bash43-033;apply=yes;striplevel=0;name=patch033 \
11 ${GNU_MIRROR}/bash/bash-4.3-patches/bash43-034;apply=yes;striplevel=0;name=patch034 \
12 ${GNU_MIRROR}/bash/bash-4.3-patches/bash43-035;apply=yes;striplevel=0;name=patch035 \
13 ${GNU_MIRROR}/bash/bash-4.3-patches/bash43-036;apply=yes;striplevel=0;name=patch036 \
14 ${GNU_MIRROR}/bash/bash-4.3-patches/bash43-037;apply=yes;striplevel=0;name=patch037 \
15 ${GNU_MIRROR}/bash/bash-4.3-patches/bash43-038;apply=yes;striplevel=0;name=patch038 \
16 ${GNU_MIRROR}/bash/bash-4.3-patches/bash43-039;apply=yes;striplevel=0;name=patch039 \
17 file://execute_cmd.patch;striplevel=0 \
18 file://mkbuiltins_have_stringize.patch \
19 file://build-tests.patch \
20 file://test-output.patch \
21 file://run-ptest \
22 "
23
24SRC_URI[tarball.md5sum] = "a27b3ee9be83bd3ba448c0ff52b28447"
25SRC_URI[tarball.sha256sum] = "317881019bbf2262fb814b7dd8e40632d13c3608d2f237800a8828fbb8a640dd"
26
27SRC_URI[patch031.md5sum] = "236df1ac1130a033ed0dbe2d2115f28f"
28SRC_URI[patch031.sha256sum] = "cd529f59dd0f2fdd49d619fe34691da6f0affedf87cc37cd460a9f3fe812a61d"
29SRC_URI[patch032.md5sum] = "2360f7e79cfb28526f80021025ea5909"
30SRC_URI[patch032.sha256sum] = "889357d29a6005b2c3308ca5b6286cb223b5e9c083219e5db3156282dd554f4a"
31SRC_URI[patch033.md5sum] = "b551c4ee7b8713759e4143499d0bbd48"
32SRC_URI[patch033.sha256sum] = "fb2a7787a13fbe027a7335aca6eb3c21cdbd813e9edc221274b6a9d8692eaa16"
33SRC_URI[patch034.md5sum] = "c9a56fbe0348e05a886dff97f2872b74"
34SRC_URI[patch034.sha256sum] = "f1694f04f110defe1330a851cc2768e7e57ddd2dfdb0e3e350ca0e3c214ff889"
35SRC_URI[patch035.md5sum] = "e564e8ab44ed1ca3a4e315a9f6cabdc9"
36SRC_URI[patch035.sha256sum] = "370d85e51780036f2386dc18c5efe996eba8e652fc1973f0f4f2ab55a993c1e3"
37SRC_URI[patch036.md5sum] = "b00ff66c41a7c0f06e191200981980b0"
38SRC_URI[patch036.sha256sum] = "ac5f82445b36efdb543dbfae64afed63f586d7574b833e9aa9cd5170bc5fd27c"
39SRC_URI[patch037.md5sum] = "be2a7b05f6ae560313f3c9d5f7127bda"
40SRC_URI[patch037.sha256sum] = "33f170dd7400ab3418d749c55c6391b1d161ef2de7aced1873451b3a3fca5813"
41SRC_URI[patch038.md5sum] = "61e0522830b24fbe8c0d1b010f132470"
42SRC_URI[patch038.sha256sum] = "adbeaa500ca7a82535f0e88d673661963f8a5fcdc7ad63445e68bf5b49786367"
43SRC_URI[patch039.md5sum] = "a4775487abe958536751c8ce53cdf6f9"
44SRC_URI[patch039.sha256sum] = "ab94dced2215541097691f60c3eb323cc28ef2549463e6a5334bbcc1e61e74ec"
45
46BBCLASSEXTEND = "nativesdk"