diff options
author | Dengke Du <dengke.du@windriver.com> | 2016-04-19 04:55:53 -0400 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2016-04-29 07:58:43 +0100 |
commit | 95638699957ba974ba6ce0554c857ad81b73e65e (patch) | |
tree | 67a6987956e2a410d310bffca4c9fb6bbd25de14 /meta/recipes-extended/bash/bash_4.3.30.bb | |
parent | 9c812e7d3c612c505fd4e624056e11765e5a3506 (diff) | |
download | poky-95638699957ba974ba6ce0554c857ad81b73e65e.tar.gz |
bash: fixed ptest run-builtins failed
1. redirect the stderr output of the command exec with -l option to
/dev/null.
Because when we run command exec with -l option in builtins.tests,
it is a login shell, so it would read the file /etc/profile, that
file executes the /usr/bin/resize which added by commit:
cc6360f4c4d97e0000f9d3545f381224ee99ce7d
The /usr/bin/resize is produced by busybox that source code resize.c
contains:
fprintf(stderr, ESC"7" ESC"[r" ESC"[999;999H" ESC"[6n");
In the end, it outputs an escape sequence to the stderr, so when we
compare the test output file /tmp/xx with builtins.right, it failed.
we need to redirect the stderr output to the /dev/null to solve the
problem.
2. ensure the target system contains the locales "en_US.UTF-8".
Because when run the run-builtins, it executes the source5.sub file
that contain:
LC_ALL=en_US.UTF-8
such as add the following to the local.conf:
IMAGE_LINGUAS_append = " en-us"
(From OE-Core rev: 5f82f3df7d4a7d6ae9a1ea3b6bc1d620a3d6c329)
Signed-off-by: Dengke Du <dengke.du@windriver.com>
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/bash/bash_4.3.30.bb')
-rw-r--r-- | meta/recipes-extended/bash/bash_4.3.30.bb | 1 |
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-extended/bash/bash_4.3.30.bb b/meta/recipes-extended/bash/bash_4.3.30.bb index 4426cf00a0..95ed3925c7 100644 --- a/meta/recipes-extended/bash/bash_4.3.30.bb +++ b/meta/recipes-extended/bash/bash_4.3.30.bb | |||
@@ -20,6 +20,7 @@ SRC_URI = "${GNU_MIRROR}/bash/${BP}.tar.gz;name=tarball \ | |||
20 | file://test-output.patch \ | 20 | file://test-output.patch \ |
21 | file://fix-run-coproc-run-heredoc-run-execscript-run-test-f.patch \ | 21 | file://fix-run-coproc-run-heredoc-run-execscript-run-test-f.patch \ |
22 | file://run-ptest \ | 22 | file://run-ptest \ |
23 | file://fix-run-builtins.patch \ | ||
23 | " | 24 | " |
24 | 25 | ||
25 | SRC_URI[tarball.md5sum] = "a27b3ee9be83bd3ba448c0ff52b28447" | 26 | SRC_URI[tarball.md5sum] = "a27b3ee9be83bd3ba448c0ff52b28447" |