summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/at/at_3.1.12.bb
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2010-09-02 10:04:19 -0700
committerRichard Purdie <rpurdie@linux.intel.com>2010-09-02 22:17:11 +0100
commit2eeb0943ac5b3d8f942ae7f9cf655c12827483ae (patch)
treea9851783ca24013d11b34c76d8f0bf73cf1840eb /meta/recipes-extended/at/at_3.1.12.bb
parent558ef570975f6f83a1878a41ecd984ef07a1a443 (diff)
downloadpoky-2eeb0943ac5b3d8f942ae7f9cf655c12827483ae.tar.gz
at: fix for parallel build issue & bug #180
parallel build was failing inconsistently due to missing dependancy specification in the make file. Fixed it with a new patch. Bug 180 reported this issue: | arm-poky-linux-gnueabi-gcc -march=armv5te -mtune=arm926ej-s -c -I. -fexpensive-optimizations -fomit-frame-pointer -frename-registers -O2 -ggdb -feliminate-unused-debug-types -DHAVE_CONFIG_H -DVERSION=\"3.1.12\" -DETCDIR=\"/etc\" -DLOADAVG_MX=0.8 -DDAEMON_USERNAME=\"daemon\" -DDAEMON_GROUPNAME=\"daemon\" -DLFILE=\"/var/spool/cron/atjobs/.SEQ\" -Wall atd.c | atd.c:511:2: error: #error "No mail command specified." | make: *** [atd.o] Error 1 Fixed it with the recommended solution of defining SENDMAIL as /bin/true Fixes [BUGID #180] Reorganized the recipe file for cleanlyness. Add the init script for at As per Scott's wiki instructions added the this init script for at: http://git.buildroot.net/buildroot/tree/package/at/S99at add libpam to dependancy And bumped PR. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta/recipes-extended/at/at_3.1.12.bb')
-rw-r--r--meta/recipes-extended/at/at_3.1.12.bb32
1 files changed, 26 insertions, 6 deletions
diff --git a/meta/recipes-extended/at/at_3.1.12.bb b/meta/recipes-extended/at/at_3.1.12.bb
index 605179b21f..bec09b6958 100644
--- a/meta/recipes-extended/at/at_3.1.12.bb
+++ b/meta/recipes-extended/at/at_3.1.12.bb
@@ -1,19 +1,39 @@
1require at.inc 1DESCRIPTION = "Delayed job execution and batch processing"
2 2SECTION = "base"
3LICENSE="GPLv2+" 3LICENSE="GPLv2+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4" 4LIC_FILES_CHKSUM = "file://COPYING;md5=4325afd396febcb659c36b49533135d4"
5 5DEPENDS = "flex libpam initscripts"
6PR = "r1" 6RCONFLICTS_${PN} = "atd"
7RREPLACES_${PN} = "atd"
8PR = "r2"
7 9
8SRC_URI = "${DEBIAN_MIRROR}/main/a/at/at_${PV}.orig.tar.gz \ 10SRC_URI = "${DEBIAN_MIRROR}/main/a/at/at_${PV}.orig.tar.gz \
9 file://configure.patch \ 11 file://configure.patch \
10 file://nonrootinstall.patch \ 12 file://nonrootinstall.patch \
11 file://use-ldflags.patch \ 13 file://use-ldflags.patch \
14 file://fix_parallel_build_error.patch \
12 file://posixtm.c \ 15 file://posixtm.c \
13 file://posixtm.h \ 16 file://posixtm.h \
14 file://file_replacement_with_gplv2.patch" 17 file://file_replacement_with_gplv2.patch \
18 file://S99at"
19
20EXTRA_OECONF += "ac_cv_path_SENDMAIL=/bin/true \
21 --with-daemon_username=root \
22 --with-daemon_groupname=root \
23 --with-jobdir=/var/spool/cron/atjobs \
24 --with-atspool=/var/spool/cron/atspool"
25
26inherit autotools
15 27
16do_compile_prepend () { 28do_compile_prepend () {
17 mv ${WORKDIR}/posixtm.[ch] ${S} 29 cp -f ${WORKDIR}/posixtm.[ch] ${S}
18} 30}
19 31
32do_install () {
33 oe_runmake "IROOT=${D}" install
34
35 install -d ${D}${sysconfdir}/init.d
36 install -d ${D}${sysconfdir}/rcS.d
37 install -m 0755 ${WORKDIR}/S99at ${D}${sysconfdir}/init.d/at
38 ln -sf ../init.d/at ${D}${sysconfdir}/rcS.d/S99at
39}