summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/acpica/acpitests_20140828.bb
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2017-01-10 15:55:10 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-01 11:17:44 +0000
commit94f684e4f468dfe3598f403c8fb3cdb38509eb96 (patch)
treef032f6c878f1a623cd47e7df40c19c339a08cc53 /meta/recipes-extended/acpica/acpitests_20140828.bb
parent81b7a9832f9292ced5a113f0c50e1318301f7358 (diff)
downloadpoky-94f684e4f468dfe3598f403c8fb3cdb38509eb96.tar.gz
acpica: move from meta-oe to OE-core
qemu support for UEFI in OE-core depends on OVMF, which needs the iasl tools provided by this recipe. There's also an iasl recipe in meta-luv, but than can and will be replaced by this one, thus reducing overall maintenance work. Copied from meta-openembedded rev fa65be9ba (current master). (From OE-Core rev: 020f7ea3aa5c1f311841d4fb16bc525ae1dd5f11) Signed-off-by: Patrick Ohly <patrick.ohly@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/acpica/acpitests_20140828.bb')
-rw-r--r--meta/recipes-extended/acpica/acpitests_20140828.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-extended/acpica/acpitests_20140828.bb b/meta/recipes-extended/acpica/acpitests_20140828.bb
new file mode 100644
index 0000000000..1f6f190c2e
--- /dev/null
+++ b/meta/recipes-extended/acpica/acpitests_20140828.bb
@@ -0,0 +1,35 @@
1SUMMARY = "Test suite used to validate ACPICA"
2HOMEPAGE = "http://www.acpica.org/"
3
4LICENSE = "Intel"
5LIC_FILES_CHKSUM = "file://tests/aapits/atexec.c;beginline=1;endline=115;md5=e92bcdfcd01d117d1bda3e814bb2030a"
6
7DEPENDS = "bison flex"
8
9SRC_URI = "https://acpica.org/sites/acpica/files/acpitests-unix-${PV}.tar.gz;name=acpitests \
10 https://acpica.org/sites/acpica/files/acpica-unix2-${PV}.tar.gz;name=acpica \
11 file://aapits-linux.patch \
12 file://aapits-makefile.patch \
13"
14SRC_URI[acpitests.md5sum] = "db9d6fdaa8e3eb101d700ee5ba4938ed"
15SRC_URI[acpitests.sha256sum] = "e576c74bf1bf1c9f7348bf9419e05c8acfece7105abcdc052e66670c7af2cf00"
16SRC_URI[acpica.md5sum] = "6f05f0d10166a1b1ff6107f3d1cdf1e5"
17SRC_URI[acpica.sha256sum] = "01d8867656c5ba41dec307c4383ce676196ad4281ac2c9dec9f5be5fac6d888e"
18
19S = "${WORKDIR}/acpitests-unix-${PV}"
20
21EXTRA_OEMAKE = "'CC=${TARGET_PREFIX}gcc ${HOST_CC_ARCH} ${TOOLCHAIN_OPTIONS}' 'OPT_CFLAGS=-Wall'"
22
23# The Makefiles expect a specific layout
24do_compile() {
25 cp -af ${WORKDIR}/acpica-unix2-${PV}/source ${S}
26 cd tests/aapits
27 oe_runmake
28}
29
30do_install() {
31 install -d ${D}${bindir}
32 install -m0755 tests/aapits/bin/aapits ${D}${bindir}
33}
34
35COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"