summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/acpica/acpica_20210930.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-10-19 17:33:52 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-23 17:42:26 +0100
commit16d9785c8c914d385c68f3ef18a6d0da4294051b (patch)
treeff88a733a3295b8091e83ff36c68220c8005c5f5 /meta/recipes-extended/acpica/acpica_20210930.bb
parentd72ca5de02e773cd71df2a2cc3b16eeef74c4f13 (diff)
downloadpoky-16d9785c8c914d385c68f3ef18a6d0da4294051b.tar.gz
acpica: upgrade 20210730 -> 20210930
(From OE-Core rev: b11b0e99e3e1cc74f046a09e89d284ff81c9640c) Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/acpica/acpica_20210930.bb')
-rw-r--r--meta/recipes-extended/acpica/acpica_20210930.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-extended/acpica/acpica_20210930.bb b/meta/recipes-extended/acpica/acpica_20210930.bb
new file mode 100644
index 0000000000..47f1b629ed
--- /dev/null
+++ b/meta/recipes-extended/acpica/acpica_20210930.bb
@@ -0,0 +1,51 @@
1SUMMARY = "ACPICA tools for the development and debug of ACPI tables"
2DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \
3OS-independent reference implementation of the Advanced Configuration and \
4Power Interface Specification (ACPI). ACPICA code contains those portions of \
5ACPI meant to be directly integrated into the host OS as a kernel-resident \
6subsystem, and a small set of tools to assist in developing and debugging \
7ACPI tables."
8
9HOMEPAGE = "http://www.acpica.org/"
10SECTION = "console/tools"
11
12LICENSE = "Intel | BSD-3-Clause | GPLv2"
13LIC_FILES_CHKSUM = "file://source/compiler/aslcompile.c;beginline=7;endline=150;md5=c33ce358fdcd142684e41e336b7992e8"
14
15COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
16
17DEPENDS = "m4-native flex-native bison-native"
18
19SRC_URI = "https://acpica.org/sites/acpica/files/acpica-unix-${PV}.tar.gz"
20SRC_URI[sha256sum] = "3cd82a281a16bc70c2708665668f138c4fc606c31161d46ce77230454ec04821"
21
22UPSTREAM_CHECK_URI = "https://acpica.org/downloads"
23
24S = "${WORKDIR}/acpica-unix-${PV}"
25
26inherit update-alternatives
27
28ALTERNATIVE_PRIORITY = "100"
29ALTERNATIVE:${PN} = "acpixtract acpidump"
30
31EXTRA_OEMAKE = "CC='${CC}' \
32 OPT_CFLAGS=-Wall \
33 DESTDIR=${D} \
34 PREFIX=${prefix} \
35 INSTALLDIR=${bindir} \
36 INSTALLFLAGS= \
37 YACC=bison \
38 YFLAGS='-y --file-prefix-map=${WORKDIR}=/usr/src/debug/${PN}/${EXTENDPE}${PV}-${PR}' \
39 "
40
41do_install() {
42 oe_runmake install
43}
44
45# iasl*.bb is a subset of this recipe, so RREPLACE it
46PROVIDES = "iasl"
47RPROVIDES:${PN} += "iasl"
48RREPLACES:${PN} += "iasl"
49RCONFLICTS:${PN} += "iasl"
50
51BBCLASSEXTEND = "native"