summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/acpica/acpica_20200430.bb
diff options
context:
space:
mode:
authorJoe Slater <joe.slater@windriver.com>2020-05-19 14:09:26 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-23 11:40:46 +0100
commitbce8aeaf3a9a37f35107136744fef9ef7ea5158f (patch)
tree50d484a7c58315288683c6371f2c51620d1ea06e /meta/recipes-extended/acpica/acpica_20200430.bb
parentd018908adb9d19253b9aafd908dace3f685b5bea (diff)
downloadpoky-bce8aeaf3a9a37f35107136744fef9ef7ea5158f.tar.gz
acpica: Upgrade 20200214 -> 20200430 for gcc-10 fixes
Advance to version 20200430 to avoid multiple definition errors for uninitialized variables. In this case, it is not enough to add -fcommon to CFLAGS. (From OE-Core rev: 71391aab99033f5488d44c097a25323bdf06ffc2) Signed-off-by: Joe Slater <joe.slater@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 7e1df28fb0534587d4f9305eb163f497852df4ec) Signed-off-by: Steve Sakoman <steve@sakoman.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/acpica/acpica_20200430.bb')
-rw-r--r--meta/recipes-extended/acpica/acpica_20200430.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-extended/acpica/acpica_20200430.bb b/meta/recipes-extended/acpica/acpica_20200430.bb
new file mode 100644
index 0000000000..478be7f56e
--- /dev/null
+++ b/meta/recipes-extended/acpica/acpica_20200430.bb
@@ -0,0 +1,49 @@
1SUMMARY = "ACPICA tools for the development and debug of ACPI tables"
2DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \
3OS-independent reference implementation of the Advanced Configuration and \
4Power Interface Specification (ACPI). ACPICA code contains those portions of \
5ACPI meant to be directly integrated into the host OS as a kernel-resident \
6subsystem, and a small set of tools to assist in developing and debugging \
7ACPI tables."
8
9HOMEPAGE = "http://www.acpica.org/"
10SECTION = "console/tools"
11
12LICENSE = "Intel | BSD | GPLv2"
13LIC_FILES_CHKSUM = "file://source/compiler/aslcompile.c;beginline=7;endline=150;md5=6adbcb81e9ee6ae50c569b94fe12f7c5"
14
15COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
16
17DEPENDS = "m4-native flex-native bison-native"
18
19SRC_URI = "https://acpica.org/sites/acpica/files/acpica-unix-${PV}.tar.gz"
20SRC_URI[sha256sum] = "fb807f1dec31664f972af37d213abf72987afe33abf68c83051e298da35d297c"
21
22UPSTREAM_CHECK_URI = "https://acpica.org/downloads"
23
24S = "${WORKDIR}/acpica-unix-${PV}"
25
26inherit update-alternatives
27
28ALTERNATIVE_PRIORITY = "100"
29ALTERNATIVE_${PN} = "acpixtract acpidump"
30
31EXTRA_OEMAKE = "CC='${CC}' \
32 OPT_CFLAGS=-Wall \
33 DESTDIR=${D} \
34 PREFIX=${prefix} \
35 INSTALLDIR=${bindir} \
36 INSTALLFLAGS= \
37 "
38
39do_install() {
40 oe_runmake install
41}
42
43# iasl*.bb is a subset of this recipe, so RREPLACE it
44PROVIDES = "iasl"
45RPROVIDES_${PN} += "iasl"
46RREPLACES_${PN} += "iasl"
47RCONFLICTS_${PN} += "iasl"
48
49BBCLASSEXTEND = "native"