diff options
author | Ross Burton <ross.burton@intel.com> | 2019-04-23 18:50:17 +0200 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2019-04-25 00:05:20 +0100 |
commit | 218ce6a595fff743bd52a2e57ae55410275cc852 (patch) | |
tree | c3b49102b2716c44ef0e2aabbdff15cb886ce59e /meta/recipes-extended/acpica/acpica_20190215.bb | |
parent | 7f7a7cba4dcd99d7b36a0d747bfd1bba3f9c2288 (diff) | |
download | poky-218ce6a595fff743bd52a2e57ae55410275cc852.tar.gz |
acpica: upgrade to 20190215
Drop yy_scan_string patch, this only affects builds with flex 2.6.2. We
currently have 2.6.0 and when we upgrade it will be to at least 2.6.3, which
fixes the regression.
Drop manipulate_fds_instead-of-FILE.patch, the original problem was fix upstream
in May 2015[1] so the 20170303 upgrade should have dropped this patch instead of
rebasing.
Call the upstream install target with variables set appropriately, instead of
hand-coding an install.
[1] https://github.com/acpica/acpica/commit/ecb91f4c3a151cbb280ee445166e7c6f4dc441a5
(From OE-Core rev: 4e95571120c8748b2b5ef4b6a06914232b19d457)
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/acpica/acpica_20190215.bb')
-rw-r--r-- | meta/recipes-extended/acpica/acpica_20190215.bb | 49 |
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-extended/acpica/acpica_20190215.bb b/meta/recipes-extended/acpica/acpica_20190215.bb new file mode 100644 index 0000000000..d4789df933 --- /dev/null +++ b/meta/recipes-extended/acpica/acpica_20190215.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | SUMMARY = "ACPICA tools for the development and debug of ACPI tables" | ||
2 | DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \ | ||
3 | OS-independent reference implementation of the Advanced Configuration and \ | ||
4 | Power Interface Specification (ACPI). ACPICA code contains those portions of \ | ||
5 | ACPI meant to be directly integrated into the host OS as a kernel-resident \ | ||
6 | subsystem, and a small set of tools to assist in developing and debugging \ | ||
7 | ACPI tables." | ||
8 | |||
9 | HOMEPAGE = "http://www.acpica.org/" | ||
10 | SECTION = "console/tools" | ||
11 | |||
12 | LICENSE = "BSD | GPLv2" | ||
13 | LIC_FILES_CHKSUM = "file://generate/unix/readme.txt;md5=204407e197c1a01154a48f6c6280c3aa" | ||
14 | |||
15 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" | ||
16 | |||
17 | DEPENDS = "bison flex bison-native" | ||
18 | |||
19 | SRC_URI = "https://acpica.org/sites/acpica/files/acpica-unix2-${PV}.tar.gz" | ||
20 | SRC_URI[md5sum] = "0ea9047bf15dfdf3583f5266cc6da718" | ||
21 | SRC_URI[sha256sum] = "8f939ad6130862e05853837496500b3fb93037530e5ea0ca0298458522ffc2c7" | ||
22 | UPSTREAM_CHECK_URI = "https://acpica.org/downloads" | ||
23 | |||
24 | S = "${WORKDIR}/acpica-unix2-${PV}" | ||
25 | |||
26 | inherit update-alternatives | ||
27 | |||
28 | ALTERNATIVE_PRIORITY = "100" | ||
29 | ALTERNATIVE_${PN} = "acpixtract" | ||
30 | |||
31 | EXTRA_OEMAKE = "CC='${CC}' \ | ||
32 | OPT_CFLAGS=-Wall \ | ||
33 | DESTDIR=${D} \ | ||
34 | PREFIX=${prefix} \ | ||
35 | INSTALLDIR=${bindir} \ | ||
36 | INSTALLFLAGS= \ | ||
37 | " | ||
38 | |||
39 | do_install() { | ||
40 | oe_runmake install | ||
41 | } | ||
42 | |||
43 | # iasl*.bb is a subset of this recipe, so RREPLACE it | ||
44 | PROVIDES = "iasl" | ||
45 | RPROVIDES_${PN} += "iasl" | ||
46 | RREPLACES_${PN} += "iasl" | ||
47 | RCONFLICTS_${PN} += "iasl" | ||
48 | |||
49 | BBCLASSEXTEND = "native" | ||