summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/acpica/acpica_20150515.bb
diff options
context:
space:
mode:
authorFathi Boudra <fathi.boudra@linaro.org>2017-01-10 15:55:10 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-01 11:17:44 +0000
commit94f684e4f468dfe3598f403c8fb3cdb38509eb96 (patch)
treef032f6c878f1a623cd47e7df40c19c339a08cc53 /meta/recipes-extended/acpica/acpica_20150515.bb
parent81b7a9832f9292ced5a113f0c50e1318301f7358 (diff)
downloadpoky-94f684e4f468dfe3598f403c8fb3cdb38509eb96.tar.gz
acpica: move from meta-oe to OE-core
qemu support for UEFI in OE-core depends on OVMF, which needs the iasl tools provided by this recipe. There's also an iasl recipe in meta-luv, but than can and will be replaced by this one, thus reducing overall maintenance work. Copied from meta-openembedded rev fa65be9ba (current master). (From OE-Core rev: 020f7ea3aa5c1f311841d4fb16bc525ae1dd5f11) Signed-off-by: Patrick Ohly <patrick.ohly@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-extended/acpica/acpica_20150515.bb')
-rw-r--r--meta/recipes-extended/acpica/acpica_20150515.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-extended/acpica/acpica_20150515.bb b/meta/recipes-extended/acpica/acpica_20150515.bb
new file mode 100644
index 0000000000..de897e1917
--- /dev/null
+++ b/meta/recipes-extended/acpica/acpica_20150515.bb
@@ -0,0 +1,46 @@
1SUMMARY = "ACPICA tools for the development and debug of ACPI tables"
2DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \
3OS-independent reference implementation of the Advanced Configuration and \
4Power Interface Specification (ACPI). ACPICA code contains those portions of \
5ACPI meant to be directly integrated into the host OS as a kernel-resident \
6subsystem, and a small set of tools to assist in developing and debugging \
7ACPI tables."
8
9HOMEPAGE = "http://www.acpica.org/"
10SECTION = "console/tools"
11
12LICENSE = "BSD | GPLv2"
13LIC_FILES_CHKSUM = "file://generate/unix/readme.txt;md5=204407e197c1a01154a48f6c6280c3aa"
14
15COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
16
17DEPENDS = "bison flex"
18
19SRC_URI = "https://acpica.org/sites/acpica/files/acpica-unix2-${PV}.tar.gz \
20 file://no-werror.patch \
21 "
22SRC_URI[md5sum] = "2bc4a7ccc82de9df9fa964f784ecb29c"
23SRC_URI[sha256sum] = "61204ec56d71bc9bfa2ee2ade4c66f7e8541772ac72ef8ccc20b3f339cc96374"
24
25S = "${WORKDIR}/acpica-unix2-${PV}"
26
27EXTRA_OEMAKE = "CC='${CC}' 'OPT_CFLAGS=-Wall'"
28
29do_install() {
30 install -D -p -m0755 generate/unix/bin*/iasl ${D}${bindir}/iasl
31 install -D -p -m0755 generate/unix/bin*/acpibin ${D}${bindir}/acpibin
32 install -D -p -m0755 generate/unix/bin*/acpiexec ${D}${bindir}/acpiexec
33 install -D -p -m0755 generate/unix/bin*/acpihelp ${D}${bindir}/acpihelp
34 install -D -p -m0755 generate/unix/bin*/acpinames ${D}${bindir}/acpinames
35 install -D -p -m0755 generate/unix/bin*/acpisrc ${D}${bindir}/acpisrc
36 install -D -p -m0755 generate/unix/bin*/acpixtract ${D}${bindir}/acpixtract
37}
38
39# iasl*.bb is a subset of this recipe, so RREPLACE it
40PROVIDES = "iasl"
41RPROVIDES_${PN} += "iasl"
42RREPLACES_${PN} += "iasl"
43RCONFLIGHTS_${PN} += "iasl"
44
45NATIVE_INSTALL_WORKS = "1"
46BBCLASSEXTEND = "native"