diff options
author | Stacy Gaikovaia <Stacy.Gaikovaia@windriver.com> | 2020-10-13 10:44:26 -0400 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2020-10-26 22:08:36 +0000 |
commit | 6dddb2345b91a4701ccaa85eecb3ce8261d3780b (patch) | |
tree | 8cdf87cef28ee40deda35650af6ca77f54cb71d8 /meta/recipes-devtools/valgrind/valgrind_3.16.1.bb | |
parent | 14335a18ddb61625f15b483e90353174925a8871 (diff) | |
download | poky-6dddb2345b91a4701ccaa85eecb3ce8261d3780b.tar.gz |
valgrind: drd: fix pthread intercept test failures
After glibc uprev 2.31 -> 2.32, the following drd ptests
fail with the error "condition variable has not been initialized".
drd/tests/annotate_hb_err
drd/tests/annotate_sem
drd/tests/annotate_rwlock
drd/tests/annotate_order_2
drd/tests/annotate_smart_pointer
drd/tests/annotate_spinlock
drd/tests/monitor_example
drd/tests/pth_cond_race
drd/tests/pth_inconsistent_cond_wait
In glibc 2.32, the POSIX thread functions are in both
libc and libpthread, causing valgrind to misinterpert
test behaviour. This patch tells valgrind to intercept
both the libc and the libpthread functions, resolving
these ptest failures.
Here are the latest test results on qemux86-64:
=== Test Summary ===
TOTAL: 728
PASSED: 688
FAILED: 1
SKIPPED: 39
The failed test is in helgrind:
FAIL: helgrind/tests/pth_destroy_cond
Patch can be removed once we uprev valgrind.
See valgrind commit 15330adf7c2471fbaa6a0818db07078d81dbff97.
(From OE-Core rev: e8f265e957e187b4f84f566aaeec8f514e3044d6)
Signed-off-by: Stacy Gaikovaia <Stacy.Gaikovaia@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/valgrind/valgrind_3.16.1.bb')
-rw-r--r-- | meta/recipes-devtools/valgrind/valgrind_3.16.1.bb | 1 |
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind_3.16.1.bb b/meta/recipes-devtools/valgrind/valgrind_3.16.1.bb index d4ca1a7752..7508098b55 100644 --- a/meta/recipes-devtools/valgrind/valgrind_3.16.1.bb +++ b/meta/recipes-devtools/valgrind/valgrind_3.16.1.bb | |||
@@ -40,6 +40,7 @@ SRC_URI = "https://sourceware.org/pub/valgrind/valgrind-${PV}.tar.bz2 \ | |||
40 | file://s390x_vec_op_t.patch \ | 40 | file://s390x_vec_op_t.patch \ |
41 | file://0001-none-tests-fdleak_cmsg.stderr.exp-adjust-tmp-paths.patch \ | 41 | file://0001-none-tests-fdleak_cmsg.stderr.exp-adjust-tmp-paths.patch \ |
42 | file://0001-memcheck-tests-Fix-timerfd-syscall-test.patch \ | 42 | file://0001-memcheck-tests-Fix-timerfd-syscall-test.patch \ |
43 | file://0001-drd-Port-to-Fedora-33.patch \ | ||
43 | " | 44 | " |
44 | SRC_URI[md5sum] = "d1b153f1ab17cf1f311705e7a83ef589" | 45 | SRC_URI[md5sum] = "d1b153f1ab17cf1f311705e7a83ef589" |
45 | SRC_URI[sha256sum] = "c91f3a2f7b02db0f3bc99479861656154d241d2fdb265614ba918cc6720a33ca" | 46 | SRC_URI[sha256sum] = "c91f3a2f7b02db0f3bc99479861656154d241d2fdb265614ba918cc6720a33ca" |