summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/valgrind/valgrind_3.13.0.bb
diff options
context:
space:
mode:
authorSoren Brinkmann <soren.brinkmann@xilinx.com>2017-07-09 00:35:37 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-17 14:01:38 +0100
commit6b490be5d119f932996ee8d0755ec331510da3b2 (patch)
treec095864e0cd8da8a83121b693fbbfe23141e8495 /meta/recipes-devtools/valgrind/valgrind_3.13.0.bb
parentcc0d3d0936d2534e44eb4375c38d70af6148932e (diff)
downloadpoky-6b490be5d119f932996ee8d0755ec331510da3b2.tar.gz
valgrind: Update 3.12.0 -> 3.13.0
(From OE-Core rev: 99e00dc094afbff7785263b760e26e03ac09425f) Signed-off-by: Soren Brinkmann <soren.brinkmann@xilinx.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/valgrind/valgrind_3.13.0.bb')
-rw-r--r--meta/recipes-devtools/valgrind/valgrind_3.13.0.bb152
1 files changed, 152 insertions, 0 deletions
diff --git a/meta/recipes-devtools/valgrind/valgrind_3.13.0.bb b/meta/recipes-devtools/valgrind/valgrind_3.13.0.bb
new file mode 100644
index 0000000000..2ec9b9b6fc
--- /dev/null
+++ b/meta/recipes-devtools/valgrind/valgrind_3.13.0.bb
@@ -0,0 +1,152 @@
1SUMMARY = "Valgrind memory debugger and instrumentation framework"
2HOMEPAGE = "http://valgrind.org/"
3BUGTRACKER = "http://valgrind.org/support/bug_reports.html"
4LICENSE = "GPLv2 & GPLv2+ & BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
6 file://include/pub_tool_basics.h;beginline=6;endline=29;md5=d4de0407239381463cf01dd276d7c22e \
7 file://include/valgrind.h;beginline=1;endline=56;md5=ad3b317f3286b6b704575d9efe6ca5df \
8 file://COPYING.DOCS;md5=24ea4c7092233849b4394699333b5c56"
9
10X11DEPENDS = "virtual/libx11"
11DEPENDS = "${@bb.utils.contains('DISTRO_FEATURES', 'x11', '${X11DEPENDS}', '', d)} \
12 ${@bb.utils.contains('DISTRO_FEATURES', 'ptest', 'boost', '', d)} \
13 "
14
15SRC_URI = "ftp://sourceware.org/pub/valgrind/valgrind-${PV}.tar.bz2 \
16 file://fixed-perl-path.patch \
17 file://Added-support-for-PPC-instructions-mfatbu-mfatbl.patch \
18 file://run-ptest \
19 file://0002-remove-rpath.patch \
20 file://0004-Fix-out-of-tree-builds.patch \
21 file://0005-Modify-vg_test-wrapper-to-support-PTEST-formats.patch \
22 file://0001-Remove-tests-that-fail-to-build-on-some-PPC32-config.patch \
23 file://use-appropriate-march-mcpu-mfpu-for-ARM-test-apps.patch \
24 file://avoid-neon-for-targets-which-don-t-support-it.patch \
25 file://valgrind-make-ld-XXX.so-strlen-intercept-optional.patch \
26 file://0001-makefiles-Drop-setting-mcpu-to-cortex-a8-on-arm-arch.patch \
27 file://0001-str_tester.c-Limit-rawmemchr-test-to-glibc.patch \
28 file://0001-sigqueue-Rename-_sifields-to-__si_fields-on-musl.patch \
29 file://0002-context-APIs-are-not-available-on-musl.patch \
30 file://0003-correct-include-directive-path-for-config.h.patch \
31 file://0004-pth_atfork1.c-Define-error-API-for-musl.patch \
32 file://0005-tc20_verifywrap.c-Fake-__GLIBC_PREREQ-with-musl.patch \
33 file://0006-pth_detached3.c-Dereference-pthread_t-before-adding-.patch \
34 file://0001-memcheck-tests-Use-ucontext_t-instead-of-struct-ucon.patch \
35 file://0001-memcheck-arm64-Define-__THROW-if-not-already-defined.patch \
36 file://0002-memcheck-x86-Define-__THROW-if-not-defined.patch \
37 file://0003-tests-seg_override-Replace-__modify_ldt-with-syscall.patch \
38 file://link-gz-tests.patch \
39 "
40SRC_URI[md5sum] = "817dd08f1e8a66336b9ff206400a5369"
41SRC_URI[sha256sum] = "d76680ef03f00cd5e970bbdcd4e57fb1f6df7d2e2c071635ef2be74790190c3b"
42
43COMPATIBLE_HOST = '(i.86|x86_64|arm|aarch64|mips|powerpc|powerpc64).*-linux'
44
45# valgrind supports armv7 and above
46COMPATIBLE_HOST_armv4 = 'null'
47COMPATIBLE_HOST_armv5 = 'null'
48COMPATIBLE_HOST_armv6 = 'null'
49
50# X32 isn't supported by valgrind at this time
51COMPATIBLE_HOST_linux-gnux32 = 'null'
52
53# Disable for some MIPS variants
54COMPATIBLE_HOST_mipsarcho32 = "${@bb.utils.contains("TARGET_FPU", "soft", "null", ".*-linux", d)}"
55COMPATIBLE_HOST_mipsarchn32 = 'null'
56COMPATIBLE_HOST_mipsarchn64 = "${@bb.utils.contains("TARGET_FPU", "soft", "null", ".*-linux", d)}"
57COMPATIBLE_HOST_mipsarchr6 = 'null'
58
59inherit autotools ptest
60
61EXTRA_OECONF = "--enable-tls --without-mpicc"
62EXTRA_OECONF += "${@['--enable-only32bit','--enable-only64bit'][d.getVar('SITEINFO_BITS') != '32']}"
63
64# valgrind checks host_cpu "armv7*)", so we need to over-ride the autotools.bbclass default --host option
65EXTRA_OECONF_append_arm = " --host=armv7${HOST_VENDOR}-${HOST_OS}"
66TARGET_CC_ARCH_remove_arm = "${@get_mcpu(d)}"
67
68EXTRA_OEMAKE = "-w"
69
70CACHED_CONFIGUREVARS += "ac_cv_path_PERL='/usr/bin/env perl'"
71
72# valgrind likes to control its own optimisation flags. It generally defaults
73# to -O2 but uses -O0 for some specific test apps etc. Passing our own flags
74# (via CFLAGS) means we interfere with that. Only pass DEBUG_FLAGS to it
75# which fixes build path issue in DWARF.
76SELECTED_OPTIMIZATION = "${DEBUG_FLAGS}"
77
78def get_mcpu(d):
79 for arg in (d.getVar('TUNE_CCARGS') or '').split():
80 if arg.startswith('-mcpu='):
81 return arg
82 else:
83 continue
84 return ""
85
86do_configure_prepend () {
87 rm -rf ${S}/config.h
88}
89
90do_install_append () {
91 install -m 644 ${B}/default.supp ${D}/${libdir}/valgrind/
92}
93
94TUNE = "${@strip_mcpu(d)}"
95
96RDEPENDS_${PN} += "perl"
97
98# valgrind needs debug information for ld.so at runtime in order to
99# redirect functions like strlen.
100RRECOMMENDS_${PN} += "${TCLIBC}-dbg"
101
102RDEPENDS_${PN}-ptest += " sed perl perl-module-file-glob"
103RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils"
104
105# One of the tests contains a bogus interpreter path on purpose.
106# Skip file dependency check
107SKIP_FILEDEPS_${PN}-ptest = '1'
108
109do_compile_ptest() {
110 oe_runmake check
111}
112
113do_install_ptest() {
114 chmod +x ${B}/tests/vg_regtest
115
116 # The test application binaries are not automatically installed.
117 # Grab them from the build directory.
118 #
119 # The regression tests require scripts and data files that are not
120 # copied to the build directory. They must be copied from the
121 # source directory.
122 saved_dir=$PWD
123 for parent_dir in ${S} ${B} ; do
124 cd $parent_dir
125
126 # exclude shell or the package won't install
127 rm -rf none/tests/shell* 2>/dev/null
128
129 subdirs="tests cachegrind/tests callgrind/tests drd/tests helgrind/tests massif/tests memcheck/tests none/tests"
130
131 # Get the vg test scripts, filters, and expected files
132 for dir in $subdirs ; do
133 find $dir | cpio -pvdu ${D}${PTEST_PATH}
134 done
135 cd $saved_dir
136 done
137
138 # clean out build artifacts before building the rpm
139 find ${D}${PTEST_PATH} \
140 \( -name "Makefile*" \
141 -o -name "*.o" \
142 -o -name "*.c" \
143 -o -name "*.S" \
144 -o -name "*.h" \) \
145 -exec rm {} \;
146
147 # needed by massif tests
148 cp ${B}/massif/ms_print ${D}${PTEST_PATH}/massif/ms_print
149
150 # handle multilib
151 sed -i s:@libdir@:${libdir}:g ${D}${PTEST_PATH}/run-ptest
152}