summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/unfs3/unfs3_git.bb
diff options
context:
space:
mode:
authorAdrian Bunk <bunk@stusta.de>2019-07-01 11:53:09 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-07-02 08:13:07 +0100
commit3bcd44957dcdcf4b80d7891662ffcdea004974c6 (patch)
tree9f3d9ee93cddabfecc402e367791675acb5ec0a1 /meta/recipes-devtools/unfs3/unfs3_git.bb
parent548b12f6725a6917b98429434bd41ff9ded5b910 (diff)
downloadpoky-3bcd44957dcdcf4b80d7891662ffcdea004974c6.tar.gz
unfs3: Switch to new upstream location
This uses the same code revision in the new repository. (From OE-Core rev: c7d9991b7536233f33226a729edaf3ba816abc73) Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/unfs3/unfs3_git.bb')
-rw-r--r--meta/recipes-devtools/unfs3/unfs3_git.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-devtools/unfs3/unfs3_git.bb b/meta/recipes-devtools/unfs3/unfs3_git.bb
new file mode 100644
index 0000000000..4b2cd5f2ce
--- /dev/null
+++ b/meta/recipes-devtools/unfs3/unfs3_git.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Userspace NFS server v3 protocol"
2SECTION = "console/network"
3LICENSE = "unfs3"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=9475885294e17c0cc0067820d042792e"
5
6DEPENDS = "flex-native bison-native flex"
7DEPENDS += "libtirpc"
8DEPENDS_append_class-nativesdk = " flex-nativesdk"
9
10ASNEEDED = ""
11
12S = "${WORKDIR}/git"
13SRC_URI = "git://github.com/unfs3/unfs3.git;protocol=https \
14 file://unfs3_parallel_build.patch \
15 file://alternate_rpc_ports.patch \
16 file://fix_pid_race_parent_writes_child_pid.patch \
17 file://fix_compile_warning.patch \
18 file://rename_fh_cache.patch \
19 file://relative_max_socket_path_len.patch \
20 file://tcp_no_delay.patch \
21 file://0001-daemon.c-Libtirpc-porting-fixes.patch \
22 file://0001-attr-fix-utime-for-symlink.patch \
23 "
24SRCREV = "c12a5c69a8d59be6916cbd0e0f41c159f1962425"
25
26PV = "0.9.22+${SRCPV}"
27
28BBCLASSEXTEND = "native nativesdk"
29
30inherit autotools
31EXTRA_OECONF_append_class-native = " --sbindir=${bindir}"
32CFLAGS_append = " -I${STAGING_INCDIR}/tirpc"
33LDFLAGS_append = " -ltirpc"
34
35# Turn off these header detects else the inode search
36# will walk entire file systems and this is a real problem
37# if you have 2 TB of files to walk in your file system
38CACHED_CONFIGUREVARS = "ac_cv_header_mntent_h=no ac_cv_header_sys_mnttab_h=no"