diff options
author | Jason Wessel <jason.wessel@windriver.com> | 2014-01-29 08:57:33 -0600 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2014-01-29 17:38:48 +0000 |
commit | 8ef4a3c0e85508e6cc604d1e10d0d7b14a5b8508 (patch) | |
tree | 6e70a9044ab0dff3f36165451d0c68ae1e7cf9ae /meta/recipes-devtools/unfs3/unfs3_0.9.22.r490.bb | |
parent | 321cd5a25e3bb93d00892b97cb0861eba029a17f (diff) | |
download | poky-8ef4a3c0e85508e6cc604d1e10d0d7b14a5b8508.tar.gz |
unfs3: Fix dependencies and allow target builds
Fixed in this patch:
* All patches marked as submitted to the upstream
* Remove the pseudo dependency because unfs3 can fully stand alone
or be used with pseudo and it does not link against pseudo
* Dependencies to flex for nativesdk and target builds are fixed
such that unfs3 can be deployed into an image
* Add unfs3 references in separatebuilddir.inc because unfs3
works correctly with autotools.
(From OE-Core rev: 7d8075c64bd0734cb70d16acef36c1a17276b359)
Signed-off-by: Jason Wessel <jason.wessel@windriver.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/unfs3/unfs3_0.9.22.r490.bb')
-rw-r--r-- | meta/recipes-devtools/unfs3/unfs3_0.9.22.r490.bb | 17 |
1 files changed, 2 insertions, 15 deletions
diff --git a/meta/recipes-devtools/unfs3/unfs3_0.9.22.r490.bb b/meta/recipes-devtools/unfs3/unfs3_0.9.22.r490.bb index 3d88b42733..af2f3bbcb0 100644 --- a/meta/recipes-devtools/unfs3/unfs3_0.9.22.r490.bb +++ b/meta/recipes-devtools/unfs3/unfs3_0.9.22.r490.bb | |||
@@ -3,11 +3,8 @@ SECTION = "console/network" | |||
3 | LICENSE = "unfs3" | 3 | LICENSE = "unfs3" |
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9475885294e17c0cc0067820d042792e" | 4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=9475885294e17c0cc0067820d042792e" |
5 | 5 | ||
6 | RDEPENDS_${PN} = "pseudo" | 6 | DEPENDS = "flex-native bison-native flex" |
7 | RDEPENDS_${PN}_class-native = "pseudo-native" | 7 | DEPENDS_append_class-nativesdk += "flex-nativesdk" |
8 | RDEPENDS_${PN}_class-nativesdk = "pseudo-nativesdk" | ||
9 | DEPENDS = "flex-native bison-native" | ||
10 | DEPENDS_class-nativesdk += "flex-nativesdk" | ||
11 | 8 | ||
12 | SRC_URI[md5sum] = "3687acc4ee992e536472365dd99712a7" | 9 | SRC_URI[md5sum] = "3687acc4ee992e536472365dd99712a7" |
13 | SRC_URI[sha256sum] = "274b43ada9c6eea1da26eb7010d72889c5278984ba0b50dff4e093057d4d64f8" | 10 | SRC_URI[sha256sum] = "274b43ada9c6eea1da26eb7010d72889c5278984ba0b50dff4e093057d4d64f8" |
@@ -32,13 +29,3 @@ inherit autotools | |||
32 | # will walk entire file systems and this is a real problem | 29 | # will walk entire file systems and this is a real problem |
33 | # if you have 2 TB of files to walk in your file system | 30 | # if you have 2 TB of files to walk in your file system |
34 | CACHED_CONFIGUREVARS = "ac_cv_header_mntent_h=no ac_cv_header_sys_mnttab_h=no" | 31 | CACHED_CONFIGUREVARS = "ac_cv_header_mntent_h=no ac_cv_header_sys_mnttab_h=no" |
35 | |||
36 | # This recipe is intended for -native and -nativesdk builds only, | ||
37 | # not target installs: | ||
38 | python __anonymous () { | ||
39 | import re | ||
40 | |||
41 | pn = d.getVar("PN", True) | ||
42 | if not pn.endswith('-native') and not pn.startswith('nativesdk-'): | ||
43 | raise bb.parse.SkipPackage("unfs3 is intended for native/nativesdk builds only") | ||
44 | } | ||