summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ubootchart/ubootchart_svn.bb
diff options
context:
space:
mode:
authorMax Eliaser <max.eliaser@intel.com>2014-08-07 10:47:48 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-08-11 10:53:07 +0100
commit2917308ec3c38ae17ad4d47e90c56952fbc55d20 (patch)
tree44ec8aab60da1bd2443b08a89c6609f536a0e0a8 /meta/recipes-devtools/ubootchart/ubootchart_svn.bb
parent23ff42e8a0384cd4c9a70baab232a4478f9a76c2 (diff)
downloadpoky-2917308ec3c38ae17ad4d47e90c56952fbc55d20.tar.gz
ubootchart: delete ubootchart recipe
The Ubootchart recipe had known issues. Ubootchart itself is no longer updated upstream. Ubootchart is also now redundant with Bootchart2. If people still want ubootchart around, it can be moved to meta-oe. Ubootchart removed as part of the solution to [YOCTO #5893]. (From OE-Core rev: 8be891cd4beacc4157158808012179c35b433e4a) Signed-off-by: Max Eliaser <max.eliaser@intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/ubootchart/ubootchart_svn.bb')
-rw-r--r--meta/recipes-devtools/ubootchart/ubootchart_svn.bb39
1 files changed, 0 insertions, 39 deletions
diff --git a/meta/recipes-devtools/ubootchart/ubootchart_svn.bb b/meta/recipes-devtools/ubootchart/ubootchart_svn.bb
deleted file mode 100644
index b13755e855..0000000000
--- a/meta/recipes-devtools/ubootchart/ubootchart_svn.bb
+++ /dev/null
@@ -1,39 +0,0 @@
1SUMMARY = "A boot profiling tool"
2HOMEPAGE = "http://code.google.com/p/ubootchart/"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=8f0e2cd40e05189ec81232da84bd6e1a"
5SRCREV = "12"
6PV = "0.0+r${SRCPV}"
7PR = "r6"
8
9#RRECOMMENDS_${PN} = "acct"
10
11SRC_URI = "svn://ubootchart.googlecode.com/svn/;protocol=http;module=trunk \
12 file://sysvinit.patch;striplevel=0 \
13 file://ubootchart-stop \
14 file://ubootchart.desktop"
15
16S = "${WORKDIR}/trunk"
17
18inherit update-alternatives
19
20ALTERNATIVE_${PN} = "init"
21ALTERNATIVE_TARGET[init] = "${base_sbindir}/ubootchartd"
22ALTERNATIVE_LINK_NAME[init] = "${base_sbindir}/init"
23ALTERNATIVE_PRIORITY = "70"
24
25do_compile() {
26 ${CC} ${CFLAGS} ${LDFLAGS} ${LIBS} ${INCLUDES} ${S}/ubootchartd_bin.c -o ubootchartd_bin
27}
28
29do_install() {
30 install -m 0755 -d ${D}${base_sbindir} ${D}${sysconfdir}/ubootchart ${D}${datadir}/applications
31 install -m 0755 ${S}/ubootchartd_bin ${D}${base_sbindir}
32 install -m 0755 ${S}/ubootchartd ${D}${base_sbindir}
33 install -m 0644 ${S}/ubootchart.conf ${D}${sysconfdir}/ubootchart
34 install -m 0755 ${S}/start.sh ${D}${sysconfdir}/ubootchart
35 install -m 0755 ${S}/finish.sh ${D}${sysconfdir}/ubootchart
36
37 install -m 0755 ${WORKDIR}/ubootchart-stop ${D}${base_sbindir}
38 install -m 0644 ${WORKDIR}/ubootchart.desktop ${D}${datadir}/applications
39}