summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/tcltk/tcl_8.6.11.bb
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@arm.com>2021-07-09 17:17:38 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-07-13 14:27:53 +0100
commit49474b8edd1a6307d167d88469ab0f5ab6926b67 (patch)
tree3e2c712ddb0871d789bd81ec84559c6b851b0db1 /meta/recipes-devtools/tcltk/tcl_8.6.11.bb
parent4b016a2d472170b0037ce2bf43e729b2b6d67a1d (diff)
downloadpoky-49474b8edd1a6307d167d88469ab0f5ab6926b67.tar.gz
tcl: use AUTOTOOLS_SCRIPT_PATH
Inside tcl the configure.ac is inside a unix/ directory. Instead of setting S to BPNPV/unix and having to use ../ to reach files outside of unix, simply set S as usual and use AUTOTOOLS_SCRIPT_PATH to run the correct configure script. (From OE-Core rev: 40516f7db7c29d956038fc74dc7d8c3a7b62325a) Signed-off-by: Ross Burton <ross.burton@arm.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/tcltk/tcl_8.6.11.bb')
-rw-r--r--meta/recipes-devtools/tcltk/tcl_8.6.11.bb24
1 files changed, 12 insertions, 12 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.6.11.bb b/meta/recipes-devtools/tcltk/tcl_8.6.11.bb
index 722e4a0132..dce0fcd2c0 100644
--- a/meta/recipes-devtools/tcltk/tcl_8.6.11.bb
+++ b/meta/recipes-devtools/tcltk/tcl_8.6.11.bb
@@ -5,12 +5,12 @@ SECTION = "devel/tcltk"
5 5
6# http://www.tcl.tk/software/tcltk/license.html 6# http://www.tcl.tk/software/tcltk/license.html
7LICENSE = "tcl & BSD-3-Clause" 7LICENSE = "tcl & BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://../license.terms;md5=058f6229798281bbcac4239c788cfa38 \ 8LIC_FILES_CHKSUM = "file://license.terms;md5=058f6229798281bbcac4239c788cfa38 \
9 file://../compat/license.terms;md5=058f6229798281bbcac4239c788cfa38 \ 9 file://compat/license.terms;md5=058f6229798281bbcac4239c788cfa38 \
10 file://../library/license.terms;md5=058f6229798281bbcac4239c788cfa38 \ 10 file://library/license.terms;md5=058f6229798281bbcac4239c788cfa38 \
11 file://../macosx/license.terms;md5=058f6229798281bbcac4239c788cfa38 \ 11 file://macosx/license.terms;md5=058f6229798281bbcac4239c788cfa38 \
12 file://../tests/license.terms;md5=058f6229798281bbcac4239c788cfa38 \ 12 file://tests/license.terms;md5=058f6229798281bbcac4239c788cfa38 \
13 file://../win/license.terms;md5=058f6229798281bbcac4239c788cfa38 \ 13 file://win/license.terms;md5=058f6229798281bbcac4239c788cfa38 \
14" 14"
15 15
16DEPENDS = "tcl-native zlib" 16DEPENDS = "tcl-native zlib"
@@ -28,17 +28,17 @@ SRC_URI[sha256sum] = "cfb49aab82bd179651e23eeeb69606f51b0ddc575ca55c3d35e2457469
28 28
29SRC_URI_class-native = "${BASE_SRC_URI}" 29SRC_URI_class-native = "${BASE_SRC_URI}"
30 30
31S = "${WORKDIR}/${BPN}${PV}/unix" 31S = "${WORKDIR}/${BPN}${PV}"
32 32
33PSEUDO_IGNORE_PATHS .= ",${WORKDIR}/${BPN}${PV}"
34VER = "${PV}" 33VER = "${PV}"
35 34
36inherit autotools ptest binconfig 35inherit autotools ptest binconfig
37 36
37AUTOTOOLS_SCRIPT_PATH = "${S}/unix"
38EXTRA_OECONF = "--enable-threads --disable-rpath --enable-man-suffix" 38EXTRA_OECONF = "--enable-threads --disable-rpath --enable-man-suffix"
39 39
40do_compile_prepend() { 40do_compile_prepend() {
41 echo > ${S}/../compat/fixstrtod.c 41 echo > ${S}/compat/fixstrtod.c
42} 42}
43 43
44do_install() { 44do_install() {
@@ -53,7 +53,7 @@ do_install() {
53 install -m 0755 tclConfig.sh ${D}${libdir} 53 install -m 0755 tclConfig.sh ${D}${libdir}
54 for dir in compat generic unix; do 54 for dir in compat generic unix; do
55 install -d ${D}${includedir}/${BPN}${VER}/$dir 55 install -d ${D}${includedir}/${BPN}${VER}/$dir
56 install -m 0644 ${S}/../$dir/*.h ${D}${includedir}/${BPN}${VER}/$dir/ 56 install -m 0644 ${S}/$dir/*.h ${D}${includedir}/${BPN}${VER}/$dir/
57 done 57 done
58} 58}
59 59
@@ -76,8 +76,8 @@ do_compile_ptest() {
76 76
77do_install_ptest() { 77do_install_ptest() {
78 cp ${B}/tcltest ${D}${PTEST_PATH} 78 cp ${B}/tcltest ${D}${PTEST_PATH}
79 cp -r ${S}/../library ${D}${PTEST_PATH} 79 cp -r ${S}/library ${D}${PTEST_PATH}
80 cp -r ${S}/../tests ${D}${PTEST_PATH} 80 cp -r ${S}/tests ${D}${PTEST_PATH}
81} 81}
82 82
83# Fix some paths that might be used by Tcl extensions 83# Fix some paths that might be used by Tcl extensions