diff options
author | Laurentiu Palcu <laurentiu.palcu@intel.com> | 2013-10-16 15:41:00 +0300 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2013-10-26 15:59:11 +0100 |
commit | 3347bc49645d2d8623011e3719f68afb9f3f8d90 (patch) | |
tree | 0e59a9efecb9d9582764e547241602d4a0213ece /meta/recipes-devtools/tcltk/tcl_8.6.1.bb | |
parent | 4d68d36dbe6d04e06dcead56b29223dc34eef843 (diff) | |
download | poky-3347bc49645d2d8623011e3719f68afb9f3f8d90.tar.gz |
tcl: upgrade to 8.6.1
Following patches were removed/refreshed:
* let-DST-include-year-2099.patch - removed, fixed upstream
* tcl-add-soname.patch - refreshed
(From OE-Core rev: 0d8ff52a4c2e31c28ef9b50a4c3a380cf263992b)
Signed-off-by: Laurentiu Palcu <laurentiu.palcu@intel.com>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/tcltk/tcl_8.6.1.bb')
-rw-r--r-- | meta/recipes-devtools/tcltk/tcl_8.6.1.bb | 76 |
1 files changed, 76 insertions, 0 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.6.1.bb b/meta/recipes-devtools/tcltk/tcl_8.6.1.bb new file mode 100644 index 0000000000..e23970848f --- /dev/null +++ b/meta/recipes-devtools/tcltk/tcl_8.6.1.bb | |||
@@ -0,0 +1,76 @@ | |||
1 | DESCRIPTION = "Tool Command Language" | ||
2 | LICENSE = "BSD-3-Clause" | ||
3 | SECTION = "devel/tcltk" | ||
4 | HOMEPAGE = "http://tcl.sourceforge.net" | ||
5 | DEPENDS = "tcl-native zlib" | ||
6 | LIC_FILES_CHKSUM = "file://../license.terms;md5=3c6f62c07835353e36f0db550ccfb65a \ | ||
7 | file://../compat/license.terms;md5=3c6f62c07835353e36f0db550ccfb65a \ | ||
8 | file://../library/license.terms;md5=3c6f62c07835353e36f0db550ccfb65a \ | ||
9 | file://../macosx/license.terms;md5=3c6f62c07835353e36f0db550ccfb65a \ | ||
10 | file://../tests/license.terms;md5=3c6f62c07835353e36f0db550ccfb65a \ | ||
11 | file://../win/license.terms;md5=3c6f62c07835353e36f0db550ccfb65a \ | ||
12 | " | ||
13 | |||
14 | BASE_SRC_URI = "${SOURCEFORGE_MIRROR}/tcl/tcl${PV}-src.tar.gz \ | ||
15 | file://tcl-add-soname.patch" | ||
16 | |||
17 | SRC_URI = "${BASE_SRC_URI} \ | ||
18 | file://fix_non_native_build_issue.patch \ | ||
19 | file://fix_issue_with_old_distro_glibc.patch \ | ||
20 | file://no_packages.patch \ | ||
21 | file://tcl-remove-hardcoded-install-path.patch \ | ||
22 | " | ||
23 | SRC_URI[md5sum] = "aae4b701ee527c6e4e1a6f9c7399882e" | ||
24 | SRC_URI[sha256sum] = "16ee769248e64ba1cae6b4834fcc4e4edd7470d881410e8d58f7dd1434343514" | ||
25 | |||
26 | SRC_URI_class-native = "${BASE_SRC_URI}" | ||
27 | |||
28 | S = "${WORKDIR}/tcl${PV}/unix" | ||
29 | |||
30 | inherit autotools | ||
31 | |||
32 | DEPENDS_class-native = "" | ||
33 | |||
34 | EXTRA_OECONF = "--enable-threads --disable-rpath" | ||
35 | |||
36 | do_configure() { | ||
37 | ( cd ${S}; gnu-configize ) | ||
38 | oe_runconf | ||
39 | } | ||
40 | |||
41 | do_compile_prepend() { | ||
42 | echo > ${S}/../compat/fixstrtod.c | ||
43 | } | ||
44 | |||
45 | do_install() { | ||
46 | autotools_do_install | ||
47 | oe_libinstall -so libtcl8.6 ${D}${libdir} | ||
48 | ln -sf ./tclsh8.6 ${D}${bindir}/tclsh | ||
49 | sed -i "s+${WORKDIR}+${STAGING_INCDIR}+g" tclConfig.sh | ||
50 | sed -i "s,-L${libdir},-L=${libdir},g" tclConfig.sh | ||
51 | sed -i "s,-I${includedir},-I=${includedir},g" tclConfig.sh | ||
52 | install -d ${D}${bindir_crossscripts} | ||
53 | install -m 0755 tclConfig.sh ${D}${bindir_crossscripts} | ||
54 | cd .. | ||
55 | for dir in compat generic unix | ||
56 | do | ||
57 | install -d ${D}${includedir}/tcl${PV}/$dir | ||
58 | install -m 0644 ${S}/../$dir/*.h ${D}${includedir}/tcl${PV}/$dir/ | ||
59 | done | ||
60 | } | ||
61 | |||
62 | SYSROOT_PREPROCESS_FUNCS += "tcl_sysroot_preprocess" | ||
63 | tcl_sysroot_preprocess () { | ||
64 | sysroot_stage_dir ${D}${bindir_crossscripts} ${SYSROOT_DESTDIR}${bindir_crossscripts} | ||
65 | } | ||
66 | |||
67 | PACKAGES =+ "tcl-lib" | ||
68 | FILES_tcl-lib = "${libdir}/libtcl8.6.so*" | ||
69 | FILES_${PN} += "${libdir}/tcl8.6 ${libdir}/tcl8" | ||
70 | FILES_${PN}-dev += "${libdir}/tclConfig.sh ${libdir}/tclooConfig.sh" | ||
71 | |||
72 | # isn't getting picked up by shlibs code | ||
73 | RDEPENDS_${PN} += "tcl-lib" | ||
74 | RDEPENDS_${PN}_class-native = "" | ||
75 | |||
76 | BBCLASSEXTEND = "native" | ||