summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/tcltk/tcl_8.5.8.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:14:24 +0100
committerRichard Purdie <rpurdie@linux.intel.com>2010-08-27 15:29:45 +0100
commit29d6678fd546377459ef75cf54abeef5b969b5cf (patch)
tree8edd65790e37a00d01c3f203f773fe4b5012db18 /meta/recipes-devtools/tcltk/tcl_8.5.8.bb
parentda49de6885ee1bc424e70bc02f21f6ab920efb55 (diff)
downloadpoky-29d6678fd546377459ef75cf54abeef5b969b5cf.tar.gz
Major layout change to the packages directory
Having one monolithic packages directory makes it hard to find things and is generally overwhelming. This commit splits it into several logical sections roughly based on function, recipes.txt gives more information about the classifications used. The opportunity is also used to switch from "packages" to "recipes" as used in OpenEmbedded as the term "packages" can be confusing to people and has many different meanings. Not all recipes have been classified yet, this is just a first pass at separating things out. Some packages are moved to meta-extras as they're no longer actively used or maintained. Signed-off-by: Richard Purdie <rpurdie@linux.intel.com>
Diffstat (limited to 'meta/recipes-devtools/tcltk/tcl_8.5.8.bb')
-rw-r--r--meta/recipes-devtools/tcltk/tcl_8.5.8.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.5.8.bb b/meta/recipes-devtools/tcltk/tcl_8.5.8.bb
new file mode 100644
index 0000000000..880340067c
--- /dev/null
+++ b/meta/recipes-devtools/tcltk/tcl_8.5.8.bb
@@ -0,0 +1,62 @@
1DESCRIPTION = "Tool Command Language"
2LICENSE = "tcl"
3SECTION = "devel/tcltk"
4HOMEPAGE = "http://tcl.sourceforge.net"
5DEPENDS = "tcl-native"
6LIC_CHKSUM_FILES = "file://../license.terms;md5=7b4d3c71b2d9a8c1b373609867975570 \
7 file://../compat/license.terms;md5=7b4d3c71b2d9a8c1b373609867975570 \
8 file://../library/license.terms;md5=7b4d3c71b2d9a8c1b373609867975570 \
9 file://../macosx/license.terms;md5=7b4d3c71b2d9a8c1b373609867975570 \
10 file://../tests/license.terms;md5=7b4d3c71b2d9a8c1b373609867975570 \
11 file://../win/license.terms;md5=7b4d3c71b2d9a8c1b373609867975570 \
12 "
13
14PR = "r2"
15
16BASE_SRC_URI = "${SOURCEFORGE_MIRROR}/tcl/tcl${PV}-src.tar.gz \
17 file://tcl-add-soname.patch"
18
19SRC_URI = "${BASE_SRC_URI} \
20 file://fix_non_native_build_issue.patch"
21
22SRC_URI_virtclass-native = "${BASE_SRC_URI}"
23
24S = "${WORKDIR}/tcl${PV}/unix"
25
26inherit autotools
27
28DEPENDS_virtclass-native = ""
29
30EXTRA_OECONF = "--enable-threads"
31
32do_configure() {
33 gnu-configize
34 oe_runconf
35}
36
37do_compile_prepend() {
38 echo > ../compat/fixstrtod.c
39}
40
41do_install() {
42 autotools_do_install
43 oe_libinstall -so libtcl8.5 ${STAGING_LIBDIR}
44 ln -sf ./tclsh8.5 ${D}${bindir}/tclsh
45 sed -i "s+${WORKDIR}+${STAGING_INCDIR}+g" tclConfig.sh
46 sed -i "s,-L${libdir},," tclConfig.sh
47 install -d ${STAGING_BINDIR_CROSS}/
48 install -m 0755 tclConfig.sh ${STAGING_BINDIR_CROSS}
49 cd ..
50 for dir in compat generic unix
51 do
52 install -d ${STAGING_INCDIR}/tcl${PV}/$dir
53 install -m 0644 $dir/*.h ${STAGING_INCDIR}/tcl${PV}/$dir/
54 done
55}
56
57PACKAGES =+ "${PN}-lib"
58FILES_${PN}-lib = "${libdir}/libtcl8.5.so.*"
59FILES_${PN} += "${libdir}/tcl8.5"
60FILES_${PN}-dev += "${libdir}/tclConfig.sh"
61
62BBCLASSEXTEND = "native"