diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-09-27 23:05:27 +0100 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2012-09-28 11:07:42 +0100 |
commit | a42dffc0bab6981e1909bf25fa6f799d455affa3 (patch) | |
tree | b4056a59a6c34c05815e3a6c1cc0486f0f3aaf2a /meta/recipes-devtools/tcltk/tcl_8.5.11.bb | |
parent | b0f4a5bc234013886237b653eb6a5a19711a02e1 (diff) | |
download | poky-a42dffc0bab6981e1909bf25fa6f799d455affa3.tar.gz |
tcl: Fix dangerous do_install staging references
Nothing should ever be poking files directly into the staging/sysroot
directories, it should always go through ${D}.
This patch ensures this recipe does this and hence fixes various
potential build issues such as lack of sstate tracking of files.
(From OE-Core rev: 7642143760c0157aba80cea7b427024ee097cc2c)
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/tcltk/tcl_8.5.11.bb')
-rw-r--r-- | meta/recipes-devtools/tcltk/tcl_8.5.11.bb | 6 |
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-devtools/tcltk/tcl_8.5.11.bb b/meta/recipes-devtools/tcltk/tcl_8.5.11.bb index e5fe7d35c0..fab6057d66 100644 --- a/meta/recipes-devtools/tcltk/tcl_8.5.11.bb +++ b/meta/recipes-devtools/tcltk/tcl_8.5.11.bb | |||
@@ -44,7 +44,7 @@ do_compile_prepend() { | |||
44 | 44 | ||
45 | do_install() { | 45 | do_install() { |
46 | autotools_do_install | 46 | autotools_do_install |
47 | oe_libinstall -so libtcl8.5 ${STAGING_LIBDIR} | 47 | oe_libinstall -so libtcl8.5 ${D}${libdir} |
48 | ln -sf ./tclsh8.5 ${D}${bindir}/tclsh | 48 | ln -sf ./tclsh8.5 ${D}${bindir}/tclsh |
49 | sed -i "s+${WORKDIR}+${STAGING_INCDIR}+g" tclConfig.sh | 49 | sed -i "s+${WORKDIR}+${STAGING_INCDIR}+g" tclConfig.sh |
50 | sed -i "s,-L${libdir},-L=${libdir},g" tclConfig.sh | 50 | sed -i "s,-L${libdir},-L=${libdir},g" tclConfig.sh |
@@ -54,8 +54,8 @@ do_install() { | |||
54 | cd .. | 54 | cd .. |
55 | for dir in compat generic unix | 55 | for dir in compat generic unix |
56 | do | 56 | do |
57 | install -d ${STAGING_INCDIR}/tcl${PV}/$dir | 57 | install -d ${D}${includedir}/tcl${PV}/$dir |
58 | install -m 0644 $dir/*.h ${STAGING_INCDIR}/tcl${PV}/$dir/ | 58 | install -m 0644 $dir/*.h ${D}${includedir}/tcl${PV}/$dir/ |
59 | done | 59 | done |
60 | } | 60 | } |
61 | 61 | ||