summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_233.bb
diff options
context:
space:
mode:
authorTim Orling <timothy.t.orling@linux.intel.com>2018-01-21 16:49:53 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-23 23:43:45 +0000
commit0ac08808af63b339849c10c5f933e767125b3acd (patch)
tree18012ea6084ec157516be707c29912b0b894b0e0 /meta/recipes-devtools/systemd-bootchart/systemd-bootchart_233.bb
parent78bdc1b7246c22c8abe9fe51143e7403bc05791f (diff)
downloadpoky-0ac08808af63b339849c10c5f933e767125b3acd.tar.gz
systemd-bootchart: upgrade to v233; fix build with musl
* Drop xlocale.h patch, merged upstream * Rework patches from systemd to fix musl build - comparison_fn_t is glibc specific - musl does not provide printf.h - musl does not provide canonicalize_file_name (From OE-Core rev: 49ebc0acae1c060ab20631b9a7215e14ce150e6d) Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/systemd-bootchart/systemd-bootchart_233.bb')
-rw-r--r--meta/recipes-devtools/systemd-bootchart/systemd-bootchart_233.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_233.bb b/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_233.bb
new file mode 100644
index 0000000000..1ae21b1fbc
--- /dev/null
+++ b/meta/recipes-devtools/systemd-bootchart/systemd-bootchart_233.bb
@@ -0,0 +1,37 @@
1LICENSE = "LGPLv2.1 & GPLv2"
2LIC_FILES_CHKSUM = "file://LICENSE.LGPL2.1;md5=4fbd65380cdd255951079008b364516c \
3 file://LICENSE.GPL2;md5=751419260aa954499f7abaabaa882bbe"
4
5SRC_URI = "git://github.com/systemd/systemd-bootchart.git;protocol=https \
6"
7
8SRC_URI_append_libc-musl = " \
9 file://0001-comparison_fn_t-is-glibc-specific-use-raw-signature-.patch \
10 file://0002-musl-does-not-provide-printf-h.patch \
11 file://0003-musl-does-not-provide-canonicalize_file_name.patch \
12 "
13
14
15# Modify these as desired
16PV = "233+git${SRCPV}"
17SRCREV = "fe1c5e41e6bdb78043dad8fa863fc2df66d1dadf"
18
19S = "${WORKDIR}/git"
20
21DEPENDS = "systemd libxslt-native xmlto-native docbook-xml-dtd4-native docbook-xsl-stylesheets-native intltool"
22
23inherit pkgconfig autotools systemd distro_features_check
24
25REQUIRED_DISTRO_FEATURES = "systemd"
26
27SYSTEMD_SERVICE_${PN} = "systemd-bootchart.service"
28
29do_configure_prepend() {
30 # intltool.m4 is a soft link to /usr/share/aclocal/m4, delete it and use the one in our sysroot
31 rm -f ${S}/m4/intltool.m4
32}
33
34FILES_${PN} += "${systemd_unitdir}/systemd-bootchart"
35
36EXTRA_OECONF = " --with-rootprefix=${base_prefix} \
37 --with-rootlibdir=${base_libdir}"