diff options
author | Khem Raj <raj.khem@gmail.com> | 2019-08-05 23:45:46 -0700 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2019-08-07 16:08:15 +0100 |
commit | be88cb8424b798cbb03fa03a46db65aeb862f3dd (patch) | |
tree | b9251b25e950edc48e2a2b22360d7720a8664f6a /meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb | |
parent | 70da7c23b4c6b8ac8ec77cd8afc3143c6956dc9f (diff) | |
download | poky-be88cb8424b798cbb03fa03a46db65aeb862f3dd.tar.gz |
syslinux: Override hardcoded toolnames in Makefile
makefile assumes native toolnames e.g. ar, as, nm etc.
which causes build fails on non-x86 build hosts
objcopy: Unable to recognise the format of the input file `libcom32.elf'
(From OE-Core rev: ee9afb34fb95409148734fda1eea1fe8f81983fd)
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb')
-rw-r--r-- | meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb | 19 |
1 files changed, 17 insertions, 2 deletions
diff --git a/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb b/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb index 67e5d57d48..e9dbefb930 100644 --- a/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb +++ b/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb | |||
@@ -59,11 +59,26 @@ do_compile() { | |||
59 | 59 | ||
60 | # Rebuild only the installer; keep precompiled bootloaders | 60 | # Rebuild only the installer; keep precompiled bootloaders |
61 | # as per author's request (doc/distrib.txt) | 61 | # as per author's request (doc/distrib.txt) |
62 | oe_runmake CC="${CC} ${CFLAGS}" LD="${LD}" LDFLAGS="${LDFLAGS}" firmware="bios" installer | 62 | oe_runmake CC="${CC} ${CFLAGS}" \ |
63 | LD="${LD}" LDFLAGS="${LDFLAGS}" \ | ||
64 | OBJDUMP="${OBJDUMP}" \ | ||
65 | OBJCOPY="${OBJCOPY}" \ | ||
66 | AR="${AR}" \ | ||
67 | STRIP="${STRIP}" \ | ||
68 | NM="${NM}" \ | ||
69 | RANLIB="${RANLIB}" \ | ||
70 | firmware="bios" installer | ||
63 | } | 71 | } |
64 | 72 | ||
65 | do_install() { | 73 | do_install() { |
66 | oe_runmake CC="${CC} ${CFLAGS}" LD="${LD}" firmware="bios" install INSTALLROOT="${D}" | 74 | oe_runmake CC="${CC} ${CFLAGS}" LD="${LD}" \ |
75 | OBJDUMP="${OBJDUMP}" \ | ||
76 | OBJCOPY="${OBJCOPY}" \ | ||
77 | AR="${AR}" \ | ||
78 | STRIP="${STRIP}" \ | ||
79 | NM="${NM}" \ | ||
80 | RANLIB="${RANLIB}" \ | ||
81 | firmware="bios" install INSTALLROOT="${D}" | ||
67 | 82 | ||
68 | install -d ${D}${datadir}/syslinux/ | 83 | install -d ${D}${datadir}/syslinux/ |
69 | install -m 644 ${S}/bios/core/ldlinux.sys ${D}${datadir}/syslinux/ | 84 | install -m 644 ${S}/bios/core/ldlinux.sys ${D}${datadir}/syslinux/ |