diff options
author | Anuj Mittal <anuj.mittal@intel.com> | 2019-02-26 21:22:53 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2019-02-27 18:04:14 +0000 |
commit | 6f686a4e5117003d59c8e526246bbc283d4806fd (patch) | |
tree | e53abe6107e05ea7b6651d59b478b8080c045a69 /meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb | |
parent | a189a28dc105ff3f85c1a99591f305897b5770af (diff) | |
download | poky-6f686a4e5117003d59c8e526246bbc283d4806fd.tar.gz |
syslinux: upgrade to 6.04-pre2
For changes in this release, see:
http://www.syslinux.org/wiki/index.php?title=Syslinux_6_Changelog
Backport a patch to fix compilation failures and remove the patches that
are not needed anymore.
(From OE-Core rev: faeeb918b01f17197c70e304b1eb7a10caba5ef3)
Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb')
-rw-r--r-- | meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb | 87 |
1 files changed, 87 insertions, 0 deletions
diff --git a/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb b/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb new file mode 100644 index 0000000000..a7fc21e2fc --- /dev/null +++ b/meta/recipes-devtools/syslinux/syslinux_6.04-pre2.bb | |||
@@ -0,0 +1,87 @@ | |||
1 | SUMMARY = "Multi-purpose linux bootloader" | ||
2 | HOMEPAGE = "http://www.syslinux.org/" | ||
3 | LICENSE = "GPLv2+" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ | ||
5 | file://README;beginline=35;endline=41;md5=558f2c71cb1fb9ba511ccd4858e48e8a" | ||
6 | |||
7 | # If you really want to run syslinux, you need mtools. We just want the | ||
8 | # ldlinux.* stuff for now, so skip mtools-native | ||
9 | DEPENDS = "nasm-native util-linux e2fsprogs" | ||
10 | PV = "6.04-pre2" | ||
11 | |||
12 | SRC_URI = "https://www.zytor.com/pub/syslinux/Testing/6.04/syslinux-${PV}.tar.xz \ | ||
13 | file://syslinux-remove-clean-script.patch \ | ||
14 | file://0001-linux-syslinux-support-ext2-3-4-device.patch \ | ||
15 | file://0002-linux-syslinux-implement-open_ext2_fs.patch \ | ||
16 | file://0003-linux-syslinux-implement-install_to_ext2.patch \ | ||
17 | file://0004-linux-syslinux-add-ext_file_read-and-ext_file_write.patch \ | ||
18 | file://0005-linux-syslinux-implement-handle_adv_on_ext.patch \ | ||
19 | file://0006-linux-syslinux-implement-write_to_ext-and-add-syslin.patch \ | ||
20 | file://0007-linux-syslinux-implement-ext_construct_sectmap_fs.patch \ | ||
21 | file://0008-libinstaller-syslinuxext-implement-syslinux_patch_bo.patch \ | ||
22 | file://0009-linux-syslinux-implement-install_bootblock.patch \ | ||
23 | file://0001-install-don-t-install-obsolete-file-com32.ld.patch \ | ||
24 | " | ||
25 | |||
26 | SRC_URI[md5sum] = "2b31c78f087f99179feb357da312d7ec" | ||
27 | SRC_URI[sha256sum] = "4441a5d593f85bb6e8d578cf6653fb4ec30f9e8f4a2315a3d8f2d0a8b3fadf94" | ||
28 | |||
29 | COMPATIBLE_HOST = '(x86_64|i.86).*-(linux|freebsd.*)' | ||
30 | # Don't let the sanity checker trip on the 32 bit real mode BIOS binaries | ||
31 | INSANE_SKIP_${PN}-misc = "arch" | ||
32 | INSANE_SKIP_${PN}-chain = "arch" | ||
33 | |||
34 | EXTRA_OEMAKE = " \ | ||
35 | BINDIR=${bindir} SBINDIR=${sbindir} LIBDIR=${libdir} \ | ||
36 | DATADIR=${datadir} MANDIR=${mandir} INCDIR=${includedir} \ | ||
37 | " | ||
38 | |||
39 | do_configure() { | ||
40 | # drop win32 targets or build fails | ||
41 | sed -e 's,win32/\S*,,g' -i Makefile | ||
42 | |||
43 | # clean installer executables included in source tarball | ||
44 | oe_runmake clean firmware="efi32" EFIINC="${includedir}" | ||
45 | # NOTE: There is a temporary work around above to specify | ||
46 | # the efi32 as the firmware else the pre-built bios | ||
47 | # files get erased contrary to the doc/distib.txt | ||
48 | # In the future this should be "bios" and not "efi32". | ||
49 | } | ||
50 | |||
51 | do_compile() { | ||
52 | # Make sure the recompile is OK. | ||
53 | # Though the ${B} should always exist, still check it before find and rm. | ||
54 | [ -d "${B}" ] && find ${B} -name '.*.d' -type f -exec rm -f {} \; | ||
55 | |||
56 | # Rebuild only the installer; keep precompiled bootloaders | ||
57 | # as per author's request (doc/distrib.txt) | ||
58 | oe_runmake CC="${CC} ${CFLAGS}" LD="${LD}" LDFLAGS="${LDFLAGS}" firmware="bios" installer | ||
59 | } | ||
60 | |||
61 | do_install() { | ||
62 | oe_runmake CC="${CC} ${CFLAGS}" LD="${LD}" firmware="bios" install INSTALLROOT="${D}" | ||
63 | |||
64 | install -d ${D}${datadir}/syslinux/ | ||
65 | install -m 644 ${S}/bios/core/ldlinux.sys ${D}${datadir}/syslinux/ | ||
66 | install -m 644 ${S}/bios/core/ldlinux.bss ${D}${datadir}/syslinux/ | ||
67 | install -m 755 ${S}/bios/linux/syslinux-nomtools ${D}${bindir}/ | ||
68 | } | ||
69 | |||
70 | PACKAGES += "${PN}-nomtools ${PN}-extlinux ${PN}-mbr ${PN}-chain ${PN}-pxelinux ${PN}-isolinux ${PN}-misc" | ||
71 | |||
72 | RDEPENDS_${PN} += "mtools" | ||
73 | RDEPENDS_${PN}-nomtools += "libext2fs" | ||
74 | RDEPENDS_${PN}-misc += "perl" | ||
75 | |||
76 | FILES_${PN} = "${bindir}/syslinux" | ||
77 | FILES_${PN}-nomtools = "${bindir}/syslinux-nomtools" | ||
78 | FILES_${PN}-extlinux = "${sbindir}/extlinux" | ||
79 | FILES_${PN}-mbr = "${datadir}/${BPN}/mbr.bin" | ||
80 | FILES_${PN}-chain = "${datadir}/${BPN}/chain.c32" | ||
81 | FILES_${PN}-isolinux = "${datadir}/${BPN}/isolinux.bin" | ||
82 | FILES_${PN}-pxelinux = "${datadir}/${BPN}/pxelinux.0" | ||
83 | FILES_${PN}-dev += "${datadir}/${BPN}/com32/lib*${SOLIBS} ${datadir}/${BPN}/com32/include ${datadir}/${BPN}/com32/com32.ld" | ||
84 | FILES_${PN}-staticdev += "${datadir}/${BPN}/com32/lib*.a ${libdir}/${BPN}/com32/lib*.a" | ||
85 | FILES_${PN}-misc = "${datadir}/${BPN}/* ${libdir}/${BPN}/* ${bindir}/*" | ||
86 | |||
87 | BBCLASSEXTEND = "native nativesdk" | ||