diff options
author | Saul Wold <sgw@linux.intel.com> | 2014-12-10 10:26:33 -0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2015-01-07 23:35:08 +0000 |
commit | c4fc5641d3f994b91d685fac2602efd112a0a6a9 (patch) | |
tree | 86162b99b1839e973a4abce31c4c836b4a94e4d1 /meta/recipes-devtools/syslinux/syslinux_6.03.bb | |
parent | 31059be9777b6f452bfdaafc56d3fd3ad7fd0c65 (diff) | |
download | poky-c4fc5641d3f994b91d685fac2602efd112a0a6a9.tar.gz |
syslinux: Update to 6.0.3
Removed patches that are now committed upstream, rebase parallel make
patch and add a new patch to remove a script that was calling git during
the clean process.
(From OE-Core rev: b53e46bece1c4976ba146d9abf41a8a54c584300)
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/syslinux/syslinux_6.03.bb')
-rw-r--r-- | meta/recipes-devtools/syslinux/syslinux_6.03.bb | 77 |
1 files changed, 77 insertions, 0 deletions
diff --git a/meta/recipes-devtools/syslinux/syslinux_6.03.bb b/meta/recipes-devtools/syslinux/syslinux_6.03.bb new file mode 100644 index 0000000000..7e3176e84e --- /dev/null +++ b/meta/recipes-devtools/syslinux/syslinux_6.03.bb | |||
@@ -0,0 +1,77 @@ | |||
1 | SUMMARY = "Multi-purpose linux bootloader" | ||
2 | HOMEPAGE = "http://syslinux.zytor.com/" | ||
3 | LICENSE = "GPLv2+" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ | ||
5 | file://README;beginline=35;endline=41;md5=558f2c71cb1fb9ba511ccd4858e48e8a" | ||
6 | |||
7 | # If you really want to run syslinux, you need mtools. We just want the | ||
8 | # ldlinux.* stuff for now, so skip mtools-native | ||
9 | DEPENDS = "nasm-native util-linux" | ||
10 | |||
11 | SRC_URI = "${KERNELORG_MIRROR}/linux/utils/boot/syslinux/6.xx/syslinux-${PV}.tar.xz \ | ||
12 | file://syslinux-fix-parallel-building-issue.patch \ | ||
13 | file://syslinux-libupload-depend-lib.patch \ | ||
14 | file://syslinux-remove-clean-script.patch \ | ||
15 | " | ||
16 | |||
17 | SRC_URI[md5sum] = "92a253df9211e9c20172796ecf388f13" | ||
18 | SRC_URI[sha256sum] = "26d3986d2bea109d5dc0e4f8c4822a459276cf021125e8c9f23c3cca5d8c850e" | ||
19 | |||
20 | COMPATIBLE_HOST = '(x86_64|i.86).*-(linux|freebsd.*)' | ||
21 | # Don't let the sanity checker trip on the 32 bit real mode BIOS binaries | ||
22 | INSANE_SKIP_${PN}-misc = "arch" | ||
23 | INSANE_SKIP_${PN}-chain = "arch" | ||
24 | |||
25 | EXTRA_OEMAKE = " \ | ||
26 | BINDIR=${bindir} SBINDIR=${sbindir} LIBDIR=${libdir} \ | ||
27 | DATADIR=${datadir} MANDIR=${mandir} INCDIR=${includedir} \ | ||
28 | " | ||
29 | # syslinux uses $LD for linking, strip `-Wl,' so it can work | ||
30 | export LDFLAGS = "`echo $LDFLAGS | sed 's/-Wl,//g'`" | ||
31 | |||
32 | do_configure() { | ||
33 | # drop win32 targets or build fails | ||
34 | sed -e 's,win32/\S*,,g' -i Makefile | ||
35 | |||
36 | # clean installer executables included in source tarball | ||
37 | oe_runmake clean firmware="efi32" EFIINC="${includedir}" | ||
38 | # NOTE: There is a temporary work around above to specify | ||
39 | # the efi32 as the firmware else the pre-built bios | ||
40 | # files get erased contrary to the doc/distib.txt | ||
41 | # In the future this should be "bios" and not "efi32". | ||
42 | } | ||
43 | |||
44 | do_compile() { | ||
45 | # Make sure the recompile is OK. | ||
46 | # Though the ${B} should always exist, still check it before find and rm. | ||
47 | [ -d "${B}" ] && find ${B} -name '.*.d' -type f -exec rm -f {} \; | ||
48 | |||
49 | # Rebuild only the installer; keep precompiled bootloaders | ||
50 | # as per author's request (doc/distrib.txt) | ||
51 | oe_runmake CC="${CC} ${CFLAGS}" LDFLAGS="${LDFLAGS}" firmware="bios" installer | ||
52 | } | ||
53 | |||
54 | do_install() { | ||
55 | oe_runmake CC="${CC} ${CFLAGS}" install INSTALLROOT="${D}" firmware="bios" | ||
56 | |||
57 | install -d ${D}${datadir}/syslinux/ | ||
58 | install -m 644 ${S}/bios/core/ldlinux.sys ${D}${datadir}/syslinux/ | ||
59 | install -m 644 ${S}/bios/core/ldlinux.bss ${D}${datadir}/syslinux/ | ||
60 | } | ||
61 | |||
62 | PACKAGES += "${PN}-extlinux ${PN}-mbr ${PN}-chain ${PN}-pxelinux ${PN}-isolinux ${PN}-misc" | ||
63 | |||
64 | RDEPENDS_${PN} += "mtools" | ||
65 | RDEPENDS_${PN}-misc += "perl" | ||
66 | |||
67 | FILES_${PN} = "${bindir}/syslinux" | ||
68 | FILES_${PN}-extlinux = "${sbindir}/extlinux" | ||
69 | FILES_${PN}-mbr = "${datadir}/${BPN}/mbr.bin" | ||
70 | FILES_${PN}-chain = "${datadir}/${BPN}/chain.c32" | ||
71 | FILES_${PN}-isolinux = "${datadir}/${BPN}/isolinux.bin" | ||
72 | FILES_${PN}-pxelinux = "${datadir}/${BPN}/pxelinux.0" | ||
73 | FILES_${PN}-dev += "${datadir}/${BPN}/com32/lib*${SOLIBS} ${datadir}/${BPN}/com32/include ${datadir}/${BPN}/com32/com32.ld" | ||
74 | FILES_${PN}-staticdev += "${datadir}/${BPN}/com32/lib*.a ${libdir}/${BPN}/com32/lib*.a" | ||
75 | FILES_${PN}-misc = "${datadir}/${BPN}/* ${libdir}/${BPN}/* ${bindir}/*" | ||
76 | |||
77 | BBCLASSEXTEND = "native nativesdk" | ||