diff options
author | wangmy <wangmy@fujitsu.com> | 2021-09-15 07:37:43 +0800 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2021-10-01 14:51:45 +0100 |
commit | cf08db9f832687068909209ae36d1c01ef50bed5 (patch) | |
tree | f912da8c193ff33733fa72fb721a91389e01e539 /meta/recipes-devtools/strace/strace_5.14.bb | |
parent | c619d748ab7ef08b189a4c8bb0f4f98fd8551930 (diff) | |
download | poky-cf08db9f832687068909209ae36d1c01ef50bed5.tar.gz |
strace: upgrade 5.13 -> 5.14
Improvements
Implemented decoding of memfd_secret and quotactl_fd syscalls, introduced in Linux 5.14.
Enhanced prctl syscall decoding.
Enhanced decoding of IFLA_* netlink attributes.
Enhanced decoding of MDBA_ROUTER_PATTR_* mdb router port netlink attributes.
Updated lists of BPF_*, IORING_*, MADV_*, MOUNT_ATTR_*, SCTP_*, and UFFD_* constants.
Updated lists of ioctl commands from Linux 5.14.
Bug fixes
Fixed build using bionic libc.
(From OE-Core rev: bca3d163d9ed804b4c734ac8fe4fa96e1d05906d)
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com>
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/strace/strace_5.14.bb')
-rw-r--r-- | meta/recipes-devtools/strace/strace_5.14.bb | 56 |
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_5.14.bb b/meta/recipes-devtools/strace/strace_5.14.bb new file mode 100644 index 0000000000..02a4843edf --- /dev/null +++ b/meta/recipes-devtools/strace/strace_5.14.bb | |||
@@ -0,0 +1,56 @@ | |||
1 | SUMMARY = "System call tracing tool" | ||
2 | HOMEPAGE = "http://strace.io" | ||
3 | DESCRIPTION = "strace is a diagnostic, debugging and instructional userspace utility for Linux. It is used to monitor and tamper with interactions between processes and the Linux kernel, which include system calls, signal deliveries, and changes of process state." | ||
4 | SECTION = "console/utils" | ||
5 | LICENSE = "LGPL-2.1+ & GPL-2+" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=318cfc887fc8723f4e9d4709b55e065b" | ||
7 | |||
8 | SRC_URI = "https://strace.io/files/${PV}/strace-${PV}.tar.xz \ | ||
9 | file://update-gawk-paths.patch \ | ||
10 | file://Makefile-ptest.patch \ | ||
11 | file://run-ptest \ | ||
12 | file://mips-SIGEMT.patch \ | ||
13 | file://0001-caps-abbrev.awk-fix-gawk-s-path.patch \ | ||
14 | file://ptest-spacesave.patch \ | ||
15 | file://uintptr_t.patch \ | ||
16 | file://0001-strace-fix-reproducibilty-issues.patch \ | ||
17 | " | ||
18 | SRC_URI[sha256sum] = "901bee6db5e17debad4530dd9ffb4dc9a96c4a656edbe1c3141b7cb307b11e73" | ||
19 | |||
20 | inherit autotools ptest | ||
21 | |||
22 | PACKAGECONFIG:class-target ??= "\ | ||
23 | ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \ | ||
24 | " | ||
25 | |||
26 | PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,bluez5" | ||
27 | PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind" | ||
28 | |||
29 | EXTRA_OECONF += "--enable-mpers=no --disable-gcc-Werror" | ||
30 | |||
31 | CFLAGS:append:libc-musl = " -Dsigcontext_struct=sigcontext" | ||
32 | |||
33 | TESTDIR = "tests" | ||
34 | PTEST_BUILD_HOST_PATTERN = "^(DEB_CHANGELOGTIME|RPM_CHANGELOGTIME|WARN_CFLAGS_FOR_BUILD|LDFLAGS_FOR_BUILD)" | ||
35 | |||
36 | do_compile_ptest() { | ||
37 | oe_runmake ${PARALLEL_MAKE} -C ${TESTDIR} buildtest-TESTS | ||
38 | } | ||
39 | |||
40 | do_install_ptest() { | ||
41 | oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR} | ||
42 | mkdir -p ${D}${PTEST_PATH}/build-aux | ||
43 | mkdir -p ${D}${PTEST_PATH}/src | ||
44 | install -m 755 ${S}/build-aux/test-driver ${D}${PTEST_PATH}/build-aux/ | ||
45 | install -m 644 ${B}/src/config.h ${D}${PTEST_PATH}/src/ | ||
46 | sed -i -e '/^src/s/strace.*[0-9]/ptest/' ${D}/${PTEST_PATH}/${TESTDIR}/Makefile | ||
47 | } | ||
48 | |||
49 | RDEPENDS:${PN}-ptest += "make coreutils grep gawk sed" | ||
50 | |||
51 | RDEPENDS:${PN}-ptest:append:libc-glibc = "\ | ||
52 | locale-base-en-us.iso-8859-1 \ | ||
53 | " | ||
54 | |||
55 | BBCLASSEXTEND = "native" | ||
56 | TOOLCHAIN = "gcc" | ||