summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace_4.9.bb
diff options
context:
space:
mode:
authorChong Lu <Chong.Lu@windriver.com>2014-09-30 17:33:05 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-11-09 10:21:23 +0000
commit24ad27878c404493d01bc8cdffaad5634f854330 (patch)
treefb6954c734dc5d0884ce1165564cbb4a03fab32e /meta/recipes-devtools/strace/strace_4.9.bb
parentbfe16dbb3c237992a4d5bfc0bbd249257c3b9aff (diff)
downloadpoky-24ad27878c404493d01bc8cdffaad5634f854330.tar.gz
strace: Upgrade to 4.9
Remove two backported patches: 0001-Work-around-conflict-between-sys-ptrace.h-and-linux-.patch strace-fix-64-bit-process-detection.patch Update two patches to fit new version: Makefile-ptest.patch strace-add-configure-options.patch Add coreutils, grep and gawk to RDEPENDS_${PN}-ptest for making ptest pass. (From OE-Core rev: 826e36643a3fcb8b4ee4ed79612c63c3a9cc1536) Signed-off-by: Chong Lu <Chong.Lu@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/strace/strace_4.9.bb')
-rw-r--r--meta/recipes-devtools/strace/strace_4.9.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.9.bb b/meta/recipes-devtools/strace/strace_4.9.bb
new file mode 100644
index 0000000000..f64c6ecac4
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace_4.9.bb
@@ -0,0 +1,46 @@
1SUMMARY = "System call tracing tool"
2HOMEPAGE = "http://strace.sourceforge.net"
3SECTION = "console/utils"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=124500c21e856f0912df29295ba104c7"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
8 file://git-version-gen \
9 file://strace-add-configure-options.patch \
10 file://Makefile-ptest.patch \
11 file://run-ptest \
12 "
13
14SRC_URI[md5sum] = "885eafadb10f6c60464a266d3929a2a4"
15SRC_URI[sha256sum] = "095bfea5c540b91d297ccac73b21b92fd54a24599fd70395db87ff9eb7fd6f65"
16
17inherit autotools ptest
18RDEPENDS_${PN}-ptest += "make coreutils grep gawk"
19
20PACKAGECONFIG_class-target ?= "libaio ${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
21
22PACKAGECONFIG[libaio] = "--enable-aio,--disable-aio,libaio"
23PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl"
24
25export INCLUDES = "-I. -I./linux"
26
27TESTDIR = "tests"
28
29do_configure_prepend() {
30 cp ${WORKDIR}/git-version-gen ${S}
31}
32
33do_install_append() {
34 # We don't ship strace-graph here because it needs perl
35 rm ${D}${bindir}/strace-graph
36}
37
38do_compile_ptest() {
39 oe_runmake -C ${TESTDIR} buildtest-TESTS
40}
41
42do_install_ptest() {
43 oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
44}
45
46BBCLASSEXTEND = "native"