summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace_4.8.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
commit972dcfcdbfe75dcfeb777150c136576cf1a71e99 (patch)
tree97a61cd7e293d7ae9d56ef7ed0f81253365bb026 /meta/recipes-devtools/strace/strace_4.8.bb
downloadpoky-972dcfcdbfe75dcfeb777150c136576cf1a71e99.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-devtools/strace/strace_4.8.bb')
-rw-r--r--meta/recipes-devtools/strace/strace_4.8.bb48
1 files changed, 48 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.8.bb b/meta/recipes-devtools/strace/strace_4.8.bb
new file mode 100644
index 0000000000..ed738eaad7
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace_4.8.bb
@@ -0,0 +1,48 @@
1SUMMARY = "System call tracing tool"
2HOMEPAGE = "http://strace.sourceforge.net"
3SECTION = "console/utils"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=124500c21e856f0912df29295ba104c7"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
8 file://git-version-gen \
9 file://strace-add-configure-options.patch \
10 file://Makefile-ptest.patch \
11 file://strace-fix-64-bit-process-detection.patch \
12 file://run-ptest \
13 file://0001-Work-around-conflict-between-sys-ptrace.h-and-linux-.patch \
14 "
15
16SRC_URI[md5sum] = "c575ef43829586801f514fd91bfe7575"
17SRC_URI[sha256sum] = "f492291f07a7c805c07a8395cce1ea054a6401ad414f4cc12185672215e1d7f8"
18
19inherit autotools ptest
20RDEPENDS_${PN}-ptest += "make"
21
22PACKAGECONFIG_class-target ?= "libaio ${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
23
24PACKAGECONFIG[libaio] = "--enable-aio,--disable-aio,libaio"
25PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl"
26
27export INCLUDES = "-I. -I./linux"
28
29TESTDIR = "tests"
30
31do_configure_prepend() {
32 cp ${WORKDIR}/git-version-gen ${S}
33}
34
35do_install_append() {
36 # We don't ship strace-graph here because it needs perl
37 rm ${D}${bindir}/strace-graph
38}
39
40do_compile_ptest() {
41 oe_runmake -C ${TESTDIR} buildtest-TESTS
42}
43
44do_install_ptest() {
45 oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
46}
47
48BBCLASSEXTEND = "native"