summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace_4.17.bb
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-28 21:59:03 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-07-06 14:38:14 +0100
commit451c4649bbf384cd80af7a1552dc1f656ed2ce90 (patch)
tree26e89ce83e24fa6054ccb6d4af0d02b21544508b /meta/recipes-devtools/strace/strace_4.17.bb
parent8dec4ffdd2cc0cd4827aed8855370a6928488c87 (diff)
downloadpoky-451c4649bbf384cd80af7a1552dc1f656ed2ce90.tar.gz
strace: upgrade to 4.17
Fix build with upcoming glibc 2.26 (From OE-Core rev: 8a4a62ae44d6819cda77c96a5106b78a83364fd6) Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/strace/strace_4.17.bb')
-rw-r--r--meta/recipes-devtools/strace/strace_4.17.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.17.bb b/meta/recipes-devtools/strace/strace_4.17.bb
new file mode 100644
index 0000000000..72fa994489
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace_4.17.bb
@@ -0,0 +1,50 @@
1SUMMARY = "System call tracing tool"
2HOMEPAGE = "http://strace.sourceforge.net"
3SECTION = "console/utils"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=488acb3aaaf5d14a2e1a852d13668a70"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
8 file://disable-git-version-gen.patch \
9 file://more-robust-test-for-m32-mx32-compile-support.patch \
10 file://update-gawk-paths.patch \
11 file://Makefile-ptest.patch \
12 file://run-ptest \
13 file://0001-Fix-build-when-using-non-glibc-libc-implementation-o.patch \
14 file://mips-SIGEMT.patch \
15 file://0001-caps-abbrev.awk-fix-gawk-s-path.patch \
16 file://0008-replace-struct-ucontext-with-ucontext_t.patch \
17 "
18
19SRC_URI[md5sum] = "8d7eb10eba68bad83a269197e634b626"
20SRC_URI[sha256sum] = "81f35b085fbb3cfa806eb521a8522ac3406deaccfe121ce35064bad268237419"
21
22inherit autotools ptest bluetooth
23
24RDEPENDS_${PN}-ptest += "make coreutils grep gawk sed"
25
26PACKAGECONFIG_class-target ??= "\
27 ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
28"
29
30PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,${BLUEZ}"
31PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
32
33TESTDIR = "tests"
34
35do_install_append() {
36 # We don't ship strace-graph here because it needs perl
37 rm ${D}${bindir}/strace-graph
38}
39
40do_compile_ptest() {
41 oe_runmake -C ${TESTDIR} buildtest-TESTS
42}
43
44do_install_ptest() {
45 oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
46 sed -i -e '/^src/s/strace.*[1-9]/ptest/' ${D}/${PTEST_PATH}/${TESTDIR}/Makefile
47}
48
49BBCLASSEXTEND = "native"
50TOOLCHAIN = "gcc"