summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/strace/strace_4.10.bb
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-04-07 04:24:22 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-08 10:53:22 +0100
commit5169721033ca1c2d9a9721761930d668fa1e70ba (patch)
tree0932752be91cd4384c0971302c4ec3bc87625074 /meta/recipes-devtools/strace/strace_4.10.bb
parent6cd8c8d7466cdf29e7a94ebd4978b129da4455fa (diff)
downloadpoky-5169721033ca1c2d9a9721761930d668fa1e70ba.tar.gz
strace: 4.9 -> 4.10
Updated patches: Makefile-ptest.patch strace-add-configure-options.patch Fixed: debugedit: netlink_unix_diag: canonicalization unexpectedly shrank by one character It was because oe_runmake -C ${TESTDIR} buildtest-TESTS didn't set OS and ARCH, which caused "-I<foo>//" in gcc options, and would cause debugedit error. (From OE-Core rev: af76eb0405352d66dfd00d7f856f401d892855e1) Signed-off-by: Robert Yang <liezhi.yang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/strace/strace_4.10.bb')
-rw-r--r--meta/recipes-devtools/strace/strace_4.10.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.10.bb b/meta/recipes-devtools/strace/strace_4.10.bb
new file mode 100644
index 0000000000..416c38756a
--- /dev/null
+++ b/meta/recipes-devtools/strace/strace_4.10.bb
@@ -0,0 +1,45 @@
1SUMMARY = "System call tracing tool"
2HOMEPAGE = "http://strace.sourceforge.net"
3SECTION = "console/utils"
4LICENSE = "BSD"
5LIC_FILES_CHKSUM = "file://COPYING;md5=124500c21e856f0912df29295ba104c7"
6
7SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
8 file://git-version-gen \
9 file://strace-add-configure-options.patch \
10 file://Makefile-ptest.patch \
11 file://run-ptest \
12 "
13
14SRC_URI[md5sum] = "107a5be455493861189e9b57a3a51912"
15SRC_URI[sha256sum] = "e6180d866ef9e76586b96e2ece2bfeeb3aa23f5cc88153f76e9caedd65e40ee2"
16
17inherit autotools ptest
18RDEPENDS_${PN}-ptest += "make coreutils grep gawk"
19
20PACKAGECONFIG_class-target ?= "libaio ${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
21
22PACKAGECONFIG[libaio] = "--enable-aio,--disable-aio,libaio"
23PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl"
24PACKAGECONFIG[libunwind] = "--with-libunwind, --without-libunwind, libunwind"
25
26TESTDIR = "tests"
27
28do_configure_prepend() {
29 cp ${WORKDIR}/git-version-gen ${S}
30}
31
32do_install_append() {
33 # We don't ship strace-graph here because it needs perl
34 rm ${D}${bindir}/strace-graph
35}
36
37do_compile_ptest() {
38 oe_runmake -C ${TESTDIR} buildtest-TESTS OS=linux ARCH="${TARGET_ARCH}"
39}
40
41do_install_ptest() {
42 oe_runmake -C ${TESTDIR} install-ptest BUILDDIR=${B} DESTDIR=${D}${PTEST_PATH} TESTDIR=${TESTDIR}
43}
44
45BBCLASSEXTEND = "native"