diff options
author | Cliff Brake <cbrake@bec-systems.com> | 2011-10-21 12:39:47 -0400 |
---|---|---|
committer | Richard Purdie <richard.purdie@linuxfoundation.org> | 2011-10-24 17:27:16 +0100 |
commit | 4349f29cacf6b7f3d315ad953f738081de73b599 (patch) | |
tree | a46f59579955149a6bc2587c56b1f49700067d1f /meta/recipes-devtools/squashfs-tools/squashfs-tools_4.2.bb | |
parent | dbf48baf90b254adb685049b84a83188d078f2ac (diff) | |
download | poky-4349f29cacf6b7f3d315ad953f738081de73b599.tar.gz |
squashfs-tools: add recipe
added xz compression option, general cleanup
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/squashfs-tools/squashfs-tools_4.2.bb')
-rw-r--r-- | meta/recipes-devtools/squashfs-tools/squashfs-tools_4.2.bb | 40 |
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.2.bb b/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.2.bb new file mode 100644 index 0000000000..669179761f --- /dev/null +++ b/meta/recipes-devtools/squashfs-tools/squashfs-tools_4.2.bb | |||
@@ -0,0 +1,40 @@ | |||
1 | # Note, we can probably remove the lzma option as it has be replaced with xz, | ||
2 | # and I don't think the kernel supports it any more. | ||
3 | DESCRIPTION = "Tools to manipulate Squashfs filesystems." | ||
4 | SECTION = "base" | ||
5 | LICENSE = "GPLv2 & Public Domain" | ||
6 | LIC_FILES_CHKSUM = "file://../COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ | ||
7 | file://../../7zC.txt;beginline=12;endline=16;md5=2056cd6d919ebc3807602143c7449a7c \ | ||
8 | " | ||
9 | DEPENDS = "attr zlib xz" | ||
10 | PR = "0" | ||
11 | |||
12 | SRC_URI = "${SOURCEFORGE_MIRROR}/squashfs/squashfs${PV}.tar.gz;name=squashfs \ | ||
13 | http://downloads.sourceforge.net/sevenzip/lzma465.tar.bz2;name=lzma \ | ||
14 | " | ||
15 | SRC_URI[squashfs.md5sum] = "1b7a781fb4cf8938842279bd3e8ee852" | ||
16 | SRC_URI[squashfs.sha256sum] = "d9e0195aa922dbb665ed322b9aaa96e04a476ee650f39bbeadb0d00b24022e96" | ||
17 | SRC_URI[lzma.md5sum] = "29d5ffd03a5a3e51aef6a74e9eafb759" | ||
18 | SRC_URI[lzma.sha256sum] = "c935fd04dd8e0e8c688a3078f3675d699679a90be81c12686837e0880aa0fa1e" | ||
19 | |||
20 | S = "${WORKDIR}/squashfs${PV}/squashfs-tools" | ||
21 | |||
22 | # EXTRA_OEMAKE is typically: -e MAKEFLAGS= | ||
23 | # the -e causes problems as CFLAGS is modified in the Makefile, so | ||
24 | # we redefine EXTRA_OEMAKE here | ||
25 | EXTRA_OEMAKE = "MAKEFLAGS= LZMA_SUPPORT=1 LZMA_DIR=../.. XZ_SUPPORT=1" | ||
26 | |||
27 | do_compile() { | ||
28 | oe_runmake mksquashfs | ||
29 | } | ||
30 | do_install () { | ||
31 | install -d ${D}${sbindir} | ||
32 | install -m 0755 mksquashfs ${D}${sbindir}/ | ||
33 | } | ||
34 | |||
35 | # required to share same place with -lzma specific packages | ||
36 | FILESPATHPKG =. "squashfs-tools-${PV}:" | ||
37 | |||
38 | ARM_INSTRUCTION_SET = "arm" | ||
39 | |||
40 | BBCLASSEXTEND = "native" | ||