summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb
diff options
context:
space:
mode:
authorScott Garman <scott.a.garman@intel.com>2011-01-24 18:50:09 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-01 23:59:35 +0000
commitb8bb770e96d4c3296f8b2da497675b067145ddf6 (patch)
treeaa0584b485826145b890a9581b9a934bc28f2d32 /meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb
parent05954ef4d7d882f34e2bb1f3bc44ad6f80c11d4c (diff)
downloadpoky-b8bb770e96d4c3296f8b2da497675b067145ddf6.tar.gz
sgml-common: new recipe v0.6.3
Recipe derived from OpenEmbedded. Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Diffstat (limited to 'meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb')
-rw-r--r--meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb52
1 files changed, 52 insertions, 0 deletions
diff --git a/meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb b/meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb
new file mode 100644
index 0000000000..92014a80ee
--- /dev/null
+++ b/meta/recipes-devtools/sgml-common/sgml-common_0.6.3.bb
@@ -0,0 +1,52 @@
1SUMMARY = "Base utilities for working with SGML and XML"
2DESCRIPTION = "The sgml-common package gathers very basic \
3stuff necessary to work with SGML and XML, such as xml.dcl, \
4a SGML declaration of XML; iso-entities, a list of the basic \
5SGML ISO entities; and install-catalog, a script used to \
6add entries to (or remove entries from) centralized catalogs \
7whose entries are pointers to SGML open catalogs, \
8as defined by OASIS."
9HOMEPAGE = "http://sources.redhat.com/docbook-tools/"
10LICENSE = "GPLv2+"
11# See the comments in license.patch when upgrading this recipe.
12# This is inteded to be a temporary workaround.
13LIC_FILES_CHKSUM = "file://LICENSE-GPLv2;md5=ab8a50abe86dfc859e148baae043c89b"
14SECTION = "base"
15
16PR = "r0"
17
18SRC_URI = "ftp://sources.redhat.com/pub/docbook-tools/new-trials/SOURCES/sgml-common-${PV}.tgz \
19 file://autohell.patch \
20 file://license.patch"
21
22SRC_URI[md5sum] = "103c9828f24820df86e55e7862e28974"
23SRC_URI[sha256sum] = "7dc418c1d361123ffc5e45d61f1b97257940a8eb35d0bfbbc493381cc5b1f959"
24
25inherit autotools
26
27do_compile_append() {
28 # install-catalog script contains hardcoded references to /etc/sgml
29 sed -i -e "s|/etc/sgml|${sysconfdir}/sgml|g" bin/install-catalog
30}
31
32FILES_sgml-common_append = " ${datadir}/sgml"
33
34pkg_postinst() {
35 install-catalog \
36 --add ${sysconfdir}/sgml/sgml-ent.cat \
37 ${datadir}/sgml/sgml-iso-entities-8879.1986/catalog
38
39 install-catalog \
40 --add ${sysconfdir}/sgml/sgml-docbook.cat \
41 ${sysconfdir}/sgml/sgml-ent.cat
42}
43
44pkg_postrm() {
45 install-catalog \
46 --remove ${sysconfdir}/sgml/sgml-ent.cat \
47 ${datadir}/sgml/sgml-iso-entities-8879.1986/catalog
48
49 install-catalog \
50 --remove ${sysconfdir}/sgml/sgml-docbook.cat \
51 ${sysconfdir}/sgml/sgml-ent.cat
52}