summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb
diff options
context:
space:
mode:
authorScott Garman <scott.a.garman@intel.com>2011-01-24 18:50:09 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-01 23:59:35 +0000
commitb8bb770e96d4c3296f8b2da497675b067145ddf6 (patch)
treeaa0584b485826145b890a9581b9a934bc28f2d32 /meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb
parent05954ef4d7d882f34e2bb1f3bc44ad6f80c11d4c (diff)
downloadpoky-b8bb770e96d4c3296f8b2da497675b067145ddf6.tar.gz
sgml-common: new recipe v0.6.3
Recipe derived from OpenEmbedded. Signed-off-by: Scott Garman <scott.a.garman@intel.com>
Diffstat (limited to 'meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb')
-rw-r--r--meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb b/meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb
new file mode 100644
index 0000000000..7e9b923622
--- /dev/null
+++ b/meta/recipes-devtools/sgml-common/sgml-common-native_0.6.3.bb
@@ -0,0 +1,50 @@
1SUMMARY = "Base utilities for working with SGML and XML"
2DESCRIPTION = "The sgml-common package gathers very basic \
3stuff necessary to work with SGML and XML, such as xml.dcl, \
4a SGML declaration of XML; iso-entities, a list of the basic \
5SGML ISO entities; and install-catalog, a script used to \
6add entries to (or remove entries from) centralized catalogs \
7whose entries are pointers to SGML open catalogs, \
8as defined by OASIS."
9HOMEPAGE = "http://sources.redhat.com/docbook-tools/"
10LICENSE = "GPLv2"
11# The COPYING file sgml-common ships with is just a symlink to
12# /usr/share/automake/COPYING, which means we can't verify it
13# using our normal means. :( Hash the README file instead as
14# LIC_FILES_CHKSUM is still required.
15LIC_FILES_CHKSUM = "file://README;md5=197bd940bf13548ac2198e4f77d3da92"
16SECTION = "base"
17
18PR = "r0"
19
20require sgml-common_${PV}.bb
21inherit native
22
23S = "${WORKDIR}/sgml-common-${PV}"
24
25SYSROOT_PREPROCESS_FUNCS += "sgml_common_native_mangle"
26
27do_install_append() {
28 # install-catalog script contains hard-coded references to
29 # {sysconfdir}. Change it to ${D}${sysconfdir}.
30 sed -i -e "s|${sysconfdir}/sgml|${D}${sysconfdir}/sgml|g" ${D}${bindir}/install-catalog
31
32 ${D}${bindir}/install-catalog \
33 --add ${D}${sysconfdir}/sgml/sgml-ent.cat \
34 ${D}${datadir}/sgml/sgml-iso-entities-8879.1986/catalog
35
36 ${D}${bindir}/install-catalog \
37 --add ${D}${sysconfdir}/sgml/sgml-docbook.cat \
38 ${D}${sysconfdir}/sgml/sgml-ent.cat
39}
40
41sgml_common_native_mangle () {
42 # Revert back to ${sysconfdir} path in install-catalog
43 sed -i -e "s|${D}${sysconfdir}/sgml|${sysconfdir}/sgml|g" ${SYSROOT_DESTDIR}${STAGING_BINDIR}/install-catalog
44 # Change path from ${D}${datadir}/sgml/sgml-iso-entities-8879.1986/catalog to ${datadir}/sgml/sgml-iso-entities-8879.1986/catalog in sgml-ent.cat
45 sed -i -e "s|${D}${datadir}/sgml/sgml-iso-entities-8879.1986/catalog|${datadir}/sgml/sgml-iso-entities-8879.1986/catalog|g" ${SYSROOT_DESTDIR}${sysconfdir}/sgml/sgml-ent.cat
46 # Change path from ${D}${sysconfdir}/sgml/sgml-ent.cat|${sysconfdir}/sgml/sgml-ent.cat to ${sysconfdir}/sgml/sgml-ent.cat in sgml-ent.cat
47 sed -i -e "s|${D}${sysconfdir}/sgml/sgml-ent.cat|${sysconfdir}/sgml/sgml-ent.cat|g" ${SYSROOT_DESTDIR}${sysconfdir}/sgml/sgml-docbook.cat
48 # Remove ${D} path from catalog file created by install-catalog script
49 sed -i -e "s|${D}||g" ${SYSROOT_DESTDIR}${sysconfdir}/sgml/catalog
50}