summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rust/rust_1.55.0.bb
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2021-10-10 21:09:57 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-10-14 11:48:45 +0100
commit5efebf3be01e239f537eee9418a4414e0e4d9ab0 (patch)
tree8a8ee2c28c65564efc6250026dd05220c1c15da8 /meta/recipes-devtools/rust/rust_1.55.0.bb
parentd91db6917f109f92845109eacb4a0c9da0351387 (diff)
downloadpoky-5efebf3be01e239f537eee9418a4414e0e4d9ab0.tar.gz
rust: update 1.54.0 -> 1.55.0
(From OE-Core rev: a21705c33a6a69e9a625b8a75d76b76bd078aba2) Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rust/rust_1.55.0.bb')
-rw-r--r--meta/recipes-devtools/rust/rust_1.55.0.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rust/rust_1.55.0.bb b/meta/recipes-devtools/rust/rust_1.55.0.bb
new file mode 100644
index 0000000000..036fb43334
--- /dev/null
+++ b/meta/recipes-devtools/rust/rust_1.55.0.bb
@@ -0,0 +1,20 @@
1require rust-target.inc
2require rust-source.inc
3require rust-snapshot.inc
4
5INSANE_SKIP:${PN}:class-native = "already-stripped"
6
7do_compile () {
8 rust_runx build --stage 2
9}
10
11rust_do_install() {
12 rust_runx install
13}
14
15python () {
16 pn = d.getVar('PN')
17
18 if not pn.endswith("-native"):
19 raise bb.parse.SkipRecipe("Rust recipe doesn't work for target builds at this time. Fixes welcome.")
20}