summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/rust/libstd-rs_1.67.0.bb
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2023-01-28 17:39:12 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2023-01-31 17:11:07 +0000
commita10ec437b1387e22a6d09211b4320d5330580f49 (patch)
treedce41f4d113e2f4b531f8e0b88a4cd8d25c18345 /meta/recipes-devtools/rust/libstd-rs_1.67.0.bb
parent4360f7e2c16fae6361f3d8dffb0c34ec71c976ad (diff)
downloadpoky-a10ec437b1387e22a6d09211b4320d5330580f49.tar.gz
rust: Upgrade 1.66.1 -> 1.67.0
Disable ZStd to avoid needing libzstd in llvm (mirrors zlib disable). Generate complete list of rust-snapshot artefacts from src/stage0.json. Drop clippy-driver reproducibility change as the code is gone from upstream. Release notes: https://releases.rs/docs/1.67.0/ License-Update: Unicode-TOU text added (already in our license string) (From OE-Core rev: 4900e0c5cb8a092a1d77d4f26249afa59b241da6) Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Alexandre Belloni <alexandre.belloni@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/rust/libstd-rs_1.67.0.bb')
-rw-r--r--meta/recipes-devtools/rust/libstd-rs_1.67.0.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rust/libstd-rs_1.67.0.bb b/meta/recipes-devtools/rust/libstd-rs_1.67.0.bb
new file mode 100644
index 0000000000..f4e5abc0cc
--- /dev/null
+++ b/meta/recipes-devtools/rust/libstd-rs_1.67.0.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Rust standard libaries"
2HOMEPAGE = "http://www.rust-lang.org"
3SECTION = "devel"
4LICENSE = "(MIT | Apache-2.0) & Unicode-TOU"
5LIC_FILES_CHKSUM = "file://../../COPYRIGHT;md5=c2cccf560306876da3913d79062a54b9"
6
7require rust-source.inc
8
9# Building with library/std omits proc_macro from the sysroot. Using
10# library/test causes that to be installed which then allows cargo to
11# build (https://github.com/meta-rust/meta-rust/issues/266)
12S = "${RUSTSRC}/library/test"
13
14RUSTLIB_DEP = ""
15inherit cargo
16
17DEPENDS:append:libc-musl = " libunwind"
18# rv32 does not have libunwind ported yet
19DEPENDS:remove:riscv32 = "libunwind"
20DEPENDS:remove:riscv64 = "libunwind"
21
22# Embed bitcode in order to allow compiling both with and without LTO
23RUSTFLAGS += "-Cembed-bitcode=yes"
24# Needed so cargo can find libbacktrace
25RUSTFLAGS += "-L ${STAGING_LIBDIR} -C link-arg=-Wl,-soname,libstd.so"
26
27CARGO_FEATURES ?= "panic-unwind backtrace"
28CARGO_BUILD_FLAGS += "--features '${CARGO_FEATURES}'"
29CARGO_VENDORING_DIRECTORY = "${RUSTSRC}/vendor"
30
31do_compile:prepend () {
32 export CARGO_TARGET_DIR="${B}"
33 # For Rust 1.13.0 and newer
34 export RUSTC_BOOTSTRAP="1"
35}
36
37do_install () {
38 mkdir -p ${D}${rustlibdir}
39
40 # With the incremental build support added in 1.24, the libstd deps directory also includes dependency
41 # files that get installed. Those are really only needed to incrementally rebuild the libstd library
42 # itself and don't need to be installed.
43 rm -f ${B}/${RUST_TARGET_SYS}/${BUILD_DIR}/deps/*.d
44 cp ${B}/${RUST_TARGET_SYS}/${BUILD_DIR}/deps/* ${D}${rustlibdir}
45}
46
47BBCLASSEXTEND = "nativesdk"