summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
diff options
context:
space:
mode:
authorTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
committerTudor Florea <tudor.florea@enea.com>2015-10-09 22:59:03 +0200
commit972dcfcdbfe75dcfeb777150c136576cf1a71e99 (patch)
tree97a61cd7e293d7ae9d56ef7ed0f81253365bb026 /meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
downloadpoky-972dcfcdbfe75dcfeb777150c136576cf1a71e99.tar.gz
initial commit for Enea Linux 5.0 arm
Signed-off-by: Tudor Florea <tudor.florea@enea.com>
Diffstat (limited to 'meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb')
-rw-r--r--meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb b/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
new file mode 100644
index 0000000000..64f85c262d
--- /dev/null
+++ b/meta/recipes-devtools/run-postinsts/run-postinsts_1.0.bb
@@ -0,0 +1,42 @@
1SUMMARY = "Runs postinstall scripts on first boot of the target device"
2SECTION = "devel"
3PR = "r9"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=4d92cd373abda3937c2bc47fbc49d690 \
6 file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
7
8SRC_URI = "file://run-postinsts \
9 file://run-postinsts.init \
10 file://run-postinsts.service"
11
12inherit allarch systemd update-rc.d
13
14INITSCRIPT_NAME = "run-postinsts"
15INITSCRIPT_PARAMS = "start 99 S ."
16
17SYSTEMD_SERVICE_${PN} = "run-postinsts.service"
18
19do_configure() {
20 :
21}
22
23do_compile () {
24 :
25}
26
27do_install() {
28 install -d ${D}${sbindir}
29 install -m 0755 ${WORKDIR}/run-postinsts ${D}${sbindir}/
30
31 install -d ${D}${sysconfdir}/init.d/
32 install -m 0755 ${WORKDIR}/run-postinsts.init ${D}${sysconfdir}/init.d/run-postinsts
33
34 install -d ${D}${systemd_unitdir}/system/
35 install -m 0644 ${WORKDIR}/run-postinsts.service ${D}${systemd_unitdir}/system/
36
37 sed -i -e 's:#SYSCONFDIR#:${sysconfdir}:g' \
38 -e 's:#SBINDIR#:${sbindir}:g' \
39 -e 's:#BASE_BINDIR#:${base_bindir}:g' \
40 ${D}${sbindir}/run-postinsts \
41 ${D}${systemd_unitdir}/system/run-postinsts.service
42}