summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ruby/ruby_2.6.4.bb
diff options
context:
space:
mode:
authorAndré Draszik <andre.draszik@jci.com>2019-10-01 10:54:52 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-10-23 16:30:36 +0100
commit7fef74ae95bc8d4342b06974f6a651b5ded81054 (patch)
treebcc9ab5df4382bef931a14df9ebd6d39d878be8b /meta/recipes-devtools/ruby/ruby_2.6.4.bb
parentf82f4fae7effbf178065deed3934aec3fbf5b8b7 (diff)
downloadpoky-7fef74ae95bc8d4342b06974f6a651b5ded81054.tar.gz
ruby: update to v2.6.4
Most patches had to be refreshed Note that we can now drop EXTRA_AUTORECONF += "--exclude=aclocal" from the recipe, as ruby upstream now fully supports runnning aclocal: https://github.com/ruby/ruby/pull/1793/commits/df9bf70cd2275a3ddc3108f392214fcc4a9b0859 https://github.com/ruby/ruby/commit/ec43478f34de262ebdd2922c488e265344b489c3 Also note that 'created.rid' is not being installed anymore since v2.6.0 While additional LICENSEs were added to the recipe, they should always have been mentioned in this recipe, i.e. the license checksum was updated only because: * URLs were updated * new imported components were mentioned (with no new licenses) * formatting was changed * dates were updated (From OE-Core rev: 7124051b3b2e91e81c7b8565104ae9c5bea10be1) Signed-off-by: André Draszik <andre.draszik@jci.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-devtools/ruby/ruby_2.6.4.bb')
-rw-r--r--meta/recipes-devtools/ruby/ruby_2.6.4.bb66
1 files changed, 66 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ruby/ruby_2.6.4.bb b/meta/recipes-devtools/ruby/ruby_2.6.4.bb
new file mode 100644
index 0000000000..4554487c0a
--- /dev/null
+++ b/meta/recipes-devtools/ruby/ruby_2.6.4.bb
@@ -0,0 +1,66 @@
1require ruby.inc
2
3SRC_URI += " \
4 file://0003-configure.ac-check-finite-isinf-isnan-as-macros-firs.patch \
5 file://run-ptest \
6 "
7
8SRC_URI[md5sum] = "49b628cdb21db967d8a3f6ca6e222583"
9SRC_URI[sha256sum] = "4fc1d8ba75505b3797020a6ffc85a8bcff6adc4dabae343b6572bf281ee17937"
10
11PACKAGECONFIG ??= ""
12PACKAGECONFIG += "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
13
14PACKAGECONFIG[valgrind] = "--with-valgrind=yes, --with-valgrind=no, valgrind"
15PACKAGECONFIG[gmp] = "--with-gmp=yes, --with-gmp=no, gmp"
16PACKAGECONFIG[ipv6] = "--enable-ipv6, --disable-ipv6,"
17
18EXTRA_OECONF = "\
19 --disable-versioned-paths \
20 --disable-rpath \
21 --disable-dtrace \
22 --enable-shared \
23 --enable-load-relative \
24 --with-pkg-config=pkg-config \
25"
26
27do_install() {
28 oe_runmake 'DESTDIR=${D}' install
29}
30
31do_install_append_class-target () {
32 # Find out rbconfig.rb from .installed.list
33 rbconfig_rb=`grep rbconfig.rb ${B}/.installed.list`
34 # Remove build host directories
35 sed -i -e 's:--sysroot=${STAGING_DIR_TARGET}::g' \
36 -e s:'--with-libtool-sysroot=${STAGING_DIR_TARGET}'::g \
37 -e 's|${DEBUG_PREFIX_MAP}||g' \
38 -e 's:${HOSTTOOLS_DIR}/::g' \
39 -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
40 -e 's:${RECIPE_SYSROOT}::g' \
41 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
42 ${D}$rbconfig_rb
43}
44
45do_install_ptest () {
46 cp -rf ${S}/test ${D}${PTEST_PATH}/
47 cp -r ${S}/include ${D}/${libdir}/ruby/
48 test_case_rb=`grep rubygems/test_case.rb ${B}/.installed.list`
49 sed -i -e 's:../../../test/:../../../ptest/test/:g' ${D}/$test_case_rb
50}
51
52PACKAGES =+ "${PN}-ri-docs ${PN}-rdoc"
53
54SUMMARY_${PN}-ri-docs = "ri (Ruby Interactive) documentation for the Ruby standard library"
55RDEPENDS_${PN}-ri-docs = "${PN}"
56FILES_${PN}-ri-docs += "${datadir}/ri"
57
58SUMMARY_${PN}-rdoc = "RDoc documentation generator from Ruby source"
59RDEPENDS_${PN}-rdoc = "${PN}"
60FILES_${PN}-rdoc += "${libdir}/ruby/*/rdoc ${bindir}/rdoc"
61
62FILES_${PN} += "${datadir}/rubygems"
63
64FILES_${PN}-ptest_append_class-target += "${libdir}/ruby/include"
65
66BBCLASSEXTEND = "native"